Jonathan Van Schoick on 1 Apr 2007 16:59:01 -0000

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PhillyOnRails] Re: Newbie-ish Capistrano/SVN question

For posterity and the archives in case anyone ever searches this later on, the problem was that I had different names for the :app and :web roles, though it was the same server. So, SVN was trying to checkout the code once as role :app and then trying to do it again as role :web, but the :app role has it locked. Damn typos will kill you...

On same capistrano task topic - is anyone hosting on TextDrive? If so, have you written any tasks to re-launch dispatch.fcgi? I was poking around the TextDrive forums and nothing jumped out at me as being too elegant...


On 3/25/07, Jonathan Van Schoick <> wrote:
Hey guys,

I'm setting up my first Capistrano script and I'm running into an SVN error I hadn't seen before...

I'm using the boiler plate deploy.rb. My first deploy went fine and the /current/ directory has everything as I expected on the target server. But, when I went to deploy the second time, I'm getting an SVN error.

Cap output (some person detail removed to protect the innocent):

svn: Working copy '[[path_to_app_omitted]]/releases/20070326013138' locked
 ** [out :: [[server_name_omitted]]] svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)
    command finished
*** [update_code] transaction: rollback
  * [update_code] rolling back
  * executing "rm -rf /[[path_to_app_omitted]]/releases/20070326013138"

I ran svn status on my working copy and there's no locks. I ran svn cleanup anyway, and it comes back with no output.

Anyone run into this before? Any common stuff I should be checking out?

Any thoughts/advice are appreciated...


To unsubscribe or change your settings, visit: