Pete Foley on Tue, 30 Jan 2001 09:37:26 -0500

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Odd CRC file errors and md5 checksum mismatches - Any ideas?


I am having a very odd problem that I am unable to solve.  I have a box setup at home which is a file-print server, running woody.  When I try to copy large files to it, the files tend to get CRC errors.  So at first I thought it was my network, so I did some testing.  I made a CD image, and rar'ed it into about 50 rars.  Then tried to uncompress them.  I had to run the process several times before it finally worked - every time I ran it a different file would fail with a CRC error.  But when I would run it again, the initial erratic file would uncompress fine but another would then break.

Today, I tried to download the potato image (I did it directly from the server so I would not have to copy it over the network once it finished), and when I ran rsync, it would complain about the ISO being corrupt.  So after running rsync about 5 times and having it fail each time I decided to check out the md5 checksum on the file.  The value I got obviously was not correct.  Then I ran md5sum again, and I got a different (still incorrect) value!  In fact, each time I run it I get different values.

Does anyone know why this is happening?  I have been having the CRC problems for a while, but upon discovering this I decided that I have had enough.  I have 2 other machines running woody and neither have this problem...

Any help/ideas would be greatly appreciated... Thanks,

Philadelphia Linux Users Group       -
General Discussion  -