Cosmin Nicolaescu on 20 Apr 2005 15:02:03 -0000

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] iptables

Hash: SHA1

On Wed, April 20, 2005 10:51 am, Jeff Abrahamson said:
> I have an iptables script that's giving me trouble.  I'm hoping
> someone here can point me in the right direction.  I've attached the
script for general feedback, but here are the two (current) problems:
> 1. I tried to say
>      $IPTABLES -A INPUT -p udp,tcp --dport 123 -src $source -j ACCEPT
>    but was obliged to change that to this to be understood:
>      $IPTABLES -A INPUT -p udp --dport 123 -src $source -j ACCEPT
$IPTABLES -A INPUT -p tcp --dport 123 -src $source -j ACCEPT
>    And then I still get errors:
>        + /sbin/iptables -A INPUT -p udp --dport 123 -src
>      Bad argument `'^M
>      Try `iptables -h' or 'iptables --help' for more information.^M
> 2. My ssh session's X forwarding is blocked.  Oops.
> Note that I haven't even set policy to deny...
> Thanks in advance for any help or suggestions.
> --
>  Jeff
>  Jeff Abrahamson  <>    +1 215/837-2287 GPG
fingerprint: 1A1A BA95 D082 A558 A276  63C6 16BF 8C4C 0D1D AE4B
> ___________________________________________________________________________
Philadelphia Linux Users Group         --
> Announcements -
> General Discussion  --

Hello Jeff,

Regarding 1., the problem is syntax. If you want to use 'src' you have to
use '--src', but I just use '-s'.

About 2., what do you mean 'blocked' ? Is it blocked by a firewall, or do
you just not have X11Forwarding enabled (ssh -X or if you have openssh>3.8
you might want to use -Y to make sure Eterm or such don't just crash with
'Bad Atom' on you.

Hope this helps,

- -Cos

- --
Cosmin Nicolaescu
Systems Administrator
Drexel University
Computer Science Department
University Crossings Rm. 135

Version: GnuPG v1.4.1 (GNU/Linux)

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --