Brian Vagnoni on 15 Nov 2008 10:01:00 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] network hardware follies

----- Original Message -----
From: Eric []

> To begin to hack the device I powered it up and held the reset button
> for about 
> 1 minute (later extended to 3 minutes.)  

Bad can place the unit in factory debug mode and clear the firmware. In 
my experience you want to wait for the power up then hold the reset button down.
Try a full 11 second count with the above procedure.

> In all cases there is no
> response from 
> the default address ( on one of the LAN ports) after the
> unit was 
> "reset".  This mirrors my experience with Linksys devices which appear
> to resist 
> resetting with a tenacity usually attributed to pitbulls.

Not trying to insult your intelligence I just always like to be clear 
about these things.

You have this device connected to a network adapter on your system via
a straight cable to a lan port on the device. You have link lights at 
both ends. The network adapter on you pc is set for a static 192.168.15.x/24 
with a gateway of, correct?

You try pinging the gateway with just ping you get what error, please:

Let me know.

Also if you connect a phone to the Linksys RTP300 do you get any type of audio prompt. Like a 
voice telling you the device isn't configured yet, or just silence? Silence might be a bad sign.

Brian Vagnoni
PGP Digital Fingerprint
F076 6EEE 06E5 BEEF EBBD  BD36 F29E 850D FC32 3955

Philadelphia Linux User's Group Discussion List
Sent: Sat, 15 Nov 2008 09:06:23
Subject: [PLUG] network hardware follies

> I'm trying to reset a Linksys RTP300 that my wife obtained for me from
> Freecycle.  It is a Linux-powered VoIP router.  The history of the
> device is 
> unknown but I would presume that it's a former Vonage unit.  That may
> be a 
> totally bogus assumption, I'll admit, but where it came from is
> irrelevant IF I 
> can get it to work.

> The power is there (14.4V) and the LED's light up appropriately.  I
> even opened 
> the device and checked to be sure the reset switch actually had 0
> volts across 
> it when pressed (of course it did.)
> The courses of action I can think of are:
> 1.  Use nmap to scan like crazy trying to find the ip address that the
> unit is 
> using which I presume is in one of these ranges:
> (netmask of
>   OR
> (netmask of
> 2.  Reset it as before but remove the power supply connection and
> short the 
> power input leads for about 24 hours to be sure it's really really
> really 
> powered off.  I tried this for 1 minute with no detectable result.
> 3.  Place the unit in a local trash receptacle with unusual force.
> Following course #1 first:
> I'd like to hook it directly to a pc running Kubuntu and run nmap. 
> Can I use a 
> "crossover" Ethernet cable for that purpose?  I just happen to have
> one.  If I 
> do that is the IP address even relevant as long as it goes out of the
> Ethernet port?
> What kind of nmap scan would be the quickest and still be most likely
> detect the 
> unit?  I tried a ping scan over the home network and it takes about 40
> seconds 
> to scan the range.  At that rate the entire
> range 
> will be about 3 hours.  I'm trying not to think about the
> range. 
> Okay, okay... I thought about it: 728 hours or about 1 month.  I'd
> rather try #2 
> or #3 first :-)
> Ideas and suggestions are really welcome!  At this point I'm starting
> to run out 
> of ideas and #3 is starting to look better and better :-(
> Eric
> -- 
> #  Eric Lucas
> #
> #                "Oh, I have slipped the surly bond of earth
> #                 And danced the skies on laughter-silvered wings...
> #                                        -- John Gillespie Magee Jr
> ___________________________________________________________________________
> Philadelphia Linux Users Group         --       
> Announcements -
> General Discussion  --  
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --