Carl Johnson on 17 Jan 2010 19:11:28 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] openvpn on fc12

ok got it sorted. i'm an idiot. thanks everyone. turns out i was editing the config file in gedit and not saving the changes. seems as though the "tun0" change fixed it.
i proved that by running

[root@cjohnson openvpn]# openvpn --rmtun --dev tap0
Sun Jan 17 22:00:18 2010 TUN/TAP device tap0 opened
Sun Jan 17 22:00:18 2010 Persist state set to: OFF

before testing it again. i'm going to drop back to the user account and try again in a minute.

[root@cjohnson openvpn]# more roadwarrior.conf
dev tun0
proto udp
explicit-exit-notify 2
tun-mtu 1500
pkcs12 roadwarrior.p12
cipher BF-CBC
verb 3
ns-cert-type server
port 1234
log-append /tmp/openvpn.log
[root@cjohnson openvpn]#

On Sun, Jan 17, 2010 at 9:54 PM, brent timothy saner <> wrote:
Hash: SHA1

On 01/17/10 20:44, Carl Johnson wrote:
> still no change

whoops; just realized i keep sending you posts off-list.

here's my latest email (to the list this time!)

On 01/17/10 20:34, Carl Johnson wrote:
> > usr and group commented out
> > changed "dev tun" to dev tun0"
> > selinux and iptables are both disabled/down on this client machine.
> >
> > no change :-\

well.. shit. okay, not giving up yet.

wondering if ovpn is suid.

ls -l `which openvpn`

p.s. can you add:
verb 5
log-append /tmp/openvpn.log

to the client conf, and then paste the log file after it runs here? i
have a sneaking suspicion that it's quite possibly another issue that's
not entirely related to permissions at all, despite the error message.

OH! and yum info openvpn would be a HUGE help, too

i'll maybe load up a fedora 12 VM tonight and see if i can replicate the
issue and maybe develop a fix/solution for it.
Version: GnuPG v2.0.14 (GNU/Linux)
Comment: Using GnuPG with Mozilla -

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --