Amul Shah on 19 Jul 2010 09:35:51 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Ubuntu 8.04 -> 10.04 firefox won't start solved by removing AppArmor

  • From: "Amul Shah" <>
  • To:
  • Subject: [PLUG] Ubuntu 8.04 -> 10.04 firefox won't start solved by removing AppArmor
  • Date: Mon, 19 Jul 2010 12:35:46 -0400
  • Dkim-signature: v=1; a=rsa-sha1; c=relaxed/relaxed;; h=message-id:from:to:mime-version:content-transfer-encoding:content-type:subject:date; s=smtpout; bh=HGZZI2xyijODx0RwWbw1kD8PM7g=; b=ZImP0lDxd72INlPiDQ1cRwtGUXOEFYRkhlo4YDWtIn5jx6BheSmfyDxxTI2JvHdhT/8blRbOXxBx6Wwc0mC9c7Ra5iE6O5+Md2ryBvdKMUUkpZ/ynb06AHWhcntQuI/YyZx+J9NUKTvxy0TDeBKSQRD38pslvswG8l/RYVQ/vjg=
  • Reply-to: Philadelphia Linux User's Group Discussion List <>
  • Sender:

I recently upgraded from Ubuntu 8.04 to 10.04 and hit a major snag with FireFox that drove me nuts until a colleague said "Did you check the logs?"  Apparently the AppArmor installation, which is a default install for Ubuntu, didn't get an updated config file for handling firefox during the upgrade.  So I saw lots of these messages in /var/log/syslog
Jul 12 15:17:30 HOST kernel: [430391.312406] type=1503 audit(1278962250.757:47):  operation="file_lock" pid=11539 parent=11535 profile="/usr/lib/firefox-3.6.6/firefox-*bin" requested_mask="k::" denied_mask="k::" fsuid=301 ouid=301 name="... some file ...."

The problem:
Firefox refused to start.  It keep creating the .parentlock file and then bailed claiming that firefox was already running.
Trying to use strace to figure out what it had problems with didn't work.  Deleting my entire .mozilla config directory and then my entire home directory didn't help.  You could SSH in and use firefox, but not from the console.

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --