Randall A Sindlinger on 21 Jul 2010 06:53:19 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Confounding login problem


I have another thing to add.  Are you using nfs or autofs?  On our systems, if the system
can't mount the file system, it will take an eternity to time out.  This occurs even
for root, because it's trying to run quota, which is trying to look at all file systems.

I don't know if other remote file systems like CIFS, sshfs, or others might have similar
issues or not.  You mentioned kernel updates; keep in mind that samba moved from the
standalone smbfs to CIFS in the kernel (and the CIFS in the kernel implementation has known 
bugs). . . o 0 (There must be too many ex-Redmond folks 'helping out' in linux these days :-P )


On Wed, Jul 21, 2010 at 08:11:09AM -0400, Kevin McAllister wrote:
> Hi Art,
> When I've had login delay problems it's typically been one of:
> 1. A DNS problem. (Meaning part of PAM is wanting to do some sort of DNS lookup)
> 2. A general network problem. (somehow it's trying to do something over IPv6 or something like that)
> Now that's for remote issues, I guess you are really talking about logging in on the console.  I guess I'd look into PAM to see what sort of check is being made and timing out.
> I assume you can login first on a tty and then recreate the problem on the KDE console and check stuff from that perspective?
> - Kevin
> On Jul 21, 2010, at 5:50 AM, Art Alexion wrote:
> > I can't seem to diagnose this logically as it doesn't follow the structural logic of the system as I understand it. Any places to look will be appreciated.
> > 
> > A few major KDE or kernel updates ago, my desktop started taking 4-7 minutes to log in. Booting to the kdm login prompt is normally fast. The login problem is not limited to system boots, but also includes logout/login.
> > 
> > While the login is delayed, I cannot access any other tty to monitor the processes. I tried a different user, but the same problem. I also tried booting an older kernel, same problem.
> > 
> > Everything seems to work fine once I am logged in.
> > 
> > Ubuntu 10.04
> > KDE 4.4.2
> > 
> > Logging into gnome causes the same problem.
> > 
> > ??????
> > 
> > -- 
> > Art Alexion
Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug