Amul Shah on 3 Sep 2010 09:39:56 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] NetworkManager vs /etc/network/interfaces

  • From: "Amul Shah" <>
  • To:
  • Subject: [PLUG] NetworkManager vs /etc/network/interfaces
  • Date: Fri, 03 Sep 2010 12:39:52 -0400
  • Dkim-signature: v=1; a=rsa-sha1; c=relaxed/relaxed;; h=message-id:from:to:mime-version:content-transfer-encoding:content-type:subject:date; s=smtpout; bh=lw3b+Gbe9wUlY81aUKlvT5XTU+8=; b=pAMVLcyaqSArJHmdmKAc3+9HBGY75J4cqHESIIfuCLsOa6cXJTGmNNmPm+Avdc7+68xgIaNLw733eTVmqiwhazATxuHCWBk5gWIgQkFmfuf47uLmV8WhhsVhslV7El40jLtEnwj1N4PrkHSQnRZnTTxmdUEJvc8P9eztICO8mNs=
  • Reply-to: Philadelphia Linux User's Group Discussion List <>
  • Sender:

Hello List,
We have a problem here at work, largely due to our inexperience with NetworkManager and how it relates to the older network setup style.  We have two hosts kishoreh and shaha both running Ubuntu 10.04 (both were upgraded from 8.04).  Our machines need to have networking on startup in order to contact our NIS and NFS servers.  The machine in question, kishoreh does not because its /etc/resolv.conf is empty.  shaha works correctly whereas kishoreh does not.

I compared the following files on kishoreh to shaha with no glaring omission

    * /etc/hosts
    * /etc/dhcp3/dhclient.conf
    * /etc/nsswitch.conf

I noticed that NetworkManager was running on kishoreh, but not dhclient.  On shaha dhclient is running.  Restarting NetworkManager did not bring dhclient to life.

Started up the Network Connections application under System -> Preferences (as root) and noticed that no wired connection was configured.  So I tried creating the "Auto eth0" to match what I saw on my box.  No joy.

Bhaskar asked about /etc/network/interfaces

    root@kishoreh:~# cat /etc/network/interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet dhcp

On my machine, that last line is commented out.  We tried that (service network-manager restart) with no joy.  So I reverted the file back and did /etc/init.d/networking restart.  Joy!

So what's odd is why my machine shows "Auto eth0" in NetworkManager but kishoreh does not.  I went looking for NetworkManager config files and this is what I found.

    [10:50am] [shaha:pts/11] : /gtc/staff/shaha > sudo find /etc/NetworkManager/ -type f -ls
    725137    4 -rw-r--r--   1 root     root          315 Apr  9 21:36 /etc/NetworkManager/nm-system-settings.conf
    729613    4 -rw-r--r--   1 root     root          229 Apr 15 03:25 /etc/NetworkManager/VPN/
    725136    4 -rwxr-xr-x   1 root     root         1299 Apr  9 21:38 /etc/NetworkManager/dispatcher.d/01ifupdown

    root@kishoreh:~# find /etc/NetworkManager/ -type f -ls
    1199811    4 -rw-------   1 root     root          412 Sep  3 10:41 /etc/NetworkManager/system-connections/Auto\ eth0
    1178383    4 -rwxr-xr-x   1 root     root         1299 Apr  9 21:38 /etc/NetworkManager/dispatcher.d/01ifupdown
    1178384    4 -rw-r--r--   1 root     root          315 Apr  9 21:36 /etc/NetworkManager/nm-system-settings.conf
    1201562    4 -rw-r--r--   1 root     root          229 Apr 15 22:19 /etc/NetworkManager/VPN/
    1201549    4 -rw-r--r--   1 root     root          251 Apr 15 22:01 /etc/NetworkManager/VPN/
    1203612    4 -rw-r--r--   1 root     root          229 Apr 15 03:25 /etc/NetworkManager/VPN/

Huh? "Auth eth0" is a file on kishoreh but not my box. Nothing has that file open (lsof).  Jim mentioned a few utilities to me:

    * nm-tool                  - inspect the active interface(s)
    * nm-applet                - the applet in the gnome menu bar
    * nm-connection-editor     - the GUI configuration editor

Right now, Santosh is working so I don't want to mess around with his box.  My hunch is that I need whack that "Auto eth0" file.  But I should read some documentation first.


Philadelphia Linux Users Group         --
Announcements -
General Discussion  --