Eric H. Johnson on 21 Apr 2011 16:29:21 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Network shares

I have never really understood network shares in Linux, particularly the
pathing. I am trying to map the MythTV music folder from the back end to the
front end. The path on both the backend and frontend is:

A while back I was able to do this with the videos folder with the following
command on the frontend:
sudo mount -t nfs -o vers=3 /videos

And now trying the same thing with:
sudo mount -t nfs -o vers=3 /music

Both of these commands now yields the error "mount point /videos [or /music]
does not exist".

Since having this working with the videos folder everything has been
completely rebuilt and upgraded to 0.23 (now 0.24) which did away with the
need for a network share for the videos. Music is not working, even though I
can see all of the meta data, so I was assuming file shares were still
required for music. I have both NFS and Samba enabled on the server side,
and it seems to be setup correctly because I have no problem doing a drive
mapping from MS Windows, where I can both read and write. I have also tried
both nfs and smbfs and get basically the same result.

The full path /var/lib/mythtv/music exists on the frontend.

Can anyone explain this to me?


Philadelphia Linux Users Group         --
Announcements -
General Discussion  --