Alan D. Salewski on 20 Aug 2011 13:22:36 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Debian unstable locking up and corrupting filesystem

On Sat, Aug 20, 2011 at 02:34:03PM -0400, David B. van Balen spake thus:
> I've been having a recurring problem the past few weeks where my system will
> suddenly lock up. If this happens while I'm at the computer, I'll be able to
> move the mouse pointer around, but none of the apps will respond. If it
> happens when I'm not around, I'll come back to a blank screen and the
> computer won't respond at all. In all cases, there's nothing to do other
> than a hard reboot, after which ext3 says it can't replay the journal and
> I'll have various filesystem issues until I run an fsck. It happened again
> yesterday, and now the system won't boot.After the grub menu, I get a bunch
> of stuff like:
> [   13.720864] ata1.00: status: { DRDY ERR }
> [   13.720905] ata1.00: error: {UNC }
> [   13.744497] end_request: I/O error, dev sda, secdtor 195523
> followed by messages about not being able to mount /dev, /sys and /proc
> because there's "No such file or directory" and I'll get dumped at a BusyBox
> prompt (when I type "help" I don't see an option to run fsck, so I'll have
> to see if I can figure out another way to run it).
> In any case, I think this started happening shortly after Debian started
> packaging my ati firmware drivers in non-free, or some such. I had been
> getting errors at startup about not being able to load some firmware files,
> so I finally installed the appropriate packages about a week ago and got rid
> of the firmware error on startup. I figured that would fix the issue, but
> obviously that wasn't the case.
> Does anyone have any ideas as to what might be causing this?

I can't speak to the causes, but when it happens, have you tried logging
into the machine from a remote host (say, via ssh)?

I've had problems with video drivers in the past that would lock up my X
display in the way you describe (mouse pointer moves, but thing works),
but have still been able to ssh into the machine to shut it down

I'm sorry that that doesn't help you right now, but might be useful in
the future...


a l a n   d.   s a l e w s k i         
1024D/FA2C3588 EDFA 195F EDF1 0933 1002  6396 7C92 5CB3 FA2C 3588
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --