David Kuntz on 12 Jun 2013 15:29:55 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] XFS on CentOS-5.9

I used XFS on Centos 5.x on a number of rather large filesystems at my last shop. One was over 30TB on a storage server that got heavily utilized. It was fast, stable, and the tools are great, so even when I did have an issue it was a relatively quick fix as compared to attempting to fsck a large ext3/4 filesystem.
Nothing ever really jumped up and bit me, over the course of four years or so. XFS is an excellent filesystem, and in my experience, Just Works.

On Wed, Jun 12, 2013 at 5:40 PM, JP Vossen <jp@jpsdomain.org> wrote:
Short version: what, if anything, is going to bit me for using a 26TB XFS filesystem on CentOS-5.9?


I recently had a problem trying to format a partition larger than 16TB on CentOS-5.9 on a Dell PE720 with 8x4TB drives in a PERC H710 hardware RAID5. ÂNeither ext3 nor ext4 would work, even though in theory, and possibly with newer 'e4fsprogs', ext4 should work (after 'yum install e4fsprogs' since that's not in the stock install). ÂI had a multitude of problems, all of which boiled down to:
    1) CentOS-5.9 is *old*
    2) 32-bits is not enough

I am running x86_64, but with CentOS-5 at least, there are still far too many i386 tools and libs installed and I was hitting:
    mked4fs 1.41.12 (17-May-2010)
    mkfs.ext4: size of device /dev/sdb1 too big to be expressed in 32 bits using a blocksize of 4096

Interestingly, I was hitting that at 17.6TB, *not* the "16TB limit" that everyone else talks about (yes, I know the meaning of "TB" is fuzzy . As far as I can tell, using 8k block sizes on i386 or x86_64 is not allowed, attempts to remove the 32-bit libs failed for dependencies, and "-O 64bit" also failed as above.
    mkfs.ext4 -O 64bit,has_journal,extent,huge_file,flex_bg,uninit_bg,dir_nlink,extra_isize Â-m2 -L /data /dev/sdb1

On the other hand, XFS was backported into the CentOS stock repos, and that Just Worked, so far at least:
    yum install xfsprogs
    parted -s /dev/sdb mklabel gpt
    parted -s -- /dev/sdb mkpart primary xfs 0 -1
     # -s = script mode, no prompts
     # -- = end of options, rest are arguments
     # Start at 0 and end at '-1' = whole disk, no matter what size
    mkfs.xfs -fL /data /dev/sdb1
     # -f Â= Force
     # -L Â= Set new volume label

That worked and was *far* faster, seconds to format 26TB as opposed to 20-30 minutes for ext4 to format 17.6TB on pretty fast hardware.

So...what, if anything, is going to bit me for using this?

JP Vossen, CISSP Â Â Â Â Â Â|:::======| Â Â Âhttp://bashcookbook.com/
My Account, My Opinions   |=========|   Âhttp://www.jpsdomain.org/
"Microsoft Tax" = the additional hardware & yearly fees for the add-on
software required to protect Windows from its own poorly designed and
implemented self, while the overhead incidentally flattens Moore's Law.
Philadelphia Linux Users Group     --    Âhttp://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion Â-- Â http://lists.phillylinux.org/mailman/listinfo/plug

Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug