Greg Helledy on 5 Jul 2016 15:20:44 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Undeletable file, how to get rid of it?

One thing I had not given much thought to when I posted my question is that the NAS box that the file is sitting on is probably not using a linux file system. It is a WD MyCloud EX4, I assume it's using NTFS.

I tried this command:
>ls | cat -v -e -t
and got:
but when I tried:
>rm cifs4936$
I still got:
>rm: cannot remove ‘cifs4936$’: No such file or directory

A co-worker (who is suspicious about linux, and is responsible for that NAS device) logged in via windows NET USE, and windows shows the file being deleted, but when you go up a directory and back in, the file has re-appeared. He suggested that the FTP software was re-writing the file. I proved that false by shutting down the server...the behavior didn't change.

What would you do at this point? This isn't so much a linux question anymore, I suppose, is it time for a call to WD?

Greg Helledy
GRA, Incorporated
P:  +1 215-884-7500
F:  +1 215-884-1385

On 7/5/2016 4:01 PM, wrote:
Undeletable file, how to get rid of it?
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --