Keith C. Perry on 10 Sep 2016 14:52:48 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Cannot install grub

A couple of suggestions...

1) When you zero out the drive header make sure you are using the drive and not the partition  It is probably a good idea to zero partitions first as an additional step if you thinking something is holding onto the data in them.  The overall idea is that you want to make sure you are destroying the mbr, efi or grub bios partitions.
2) You can also use /dev/urandom instead of /dev/zero
3) Be aware of any partitions at the end of a drive and make sure you zero those too.

The worse case scenario would be to electronically shred your drive with something like "shred - n 1 /dev/sda" or "shred -z -n 1 /dev/sda" if you want zero'd drive before reinstalling.

~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~
Keith C. Perry, MS E.E.
Owner, DAO Technologies LLC
(O) +1.215.525.4165 x2033
(M) +1.215.432.5167

From: "Eric H. Johnson" <>
To: "Philadelphia Linux User's Group Discussion List" <>
Sent: Saturday, September 10, 2016 4:15:09 PM
Subject: [PLUG] Cannot install grub

Hi all,


This is about the third time this has happened installing various versions of Ubuntu, for which I have not found a solution. Basically it is installing Ubuntu Linux over a previous version. It will get most of the way through, then tell me that it cannot install grub and that it is a fatal error.


The first time it happened was in a system with a 1TB and 3 3TB drives. I screwed up the initial install to the 1 TB drive and was never able to re-install to it to that drive again, so ended up installing to one of the 3TB drives. The second time was trying to install Ubuntu over a prior version of Ubuntu. The first install used drive encryption, the second did not. I reinstalled with drive encryption, and in that case it did work.


This time I am installing Ubuntu 16.04 installing to a machine previously running Lubuntu 14.04. I also wiped out the previous partitions. It has two physical drives that were previously mirrored, but I broke the mirror and now have the drives joined (2 x 256 GB). This was done it the BIOS, so should be transparent to Linux. The install runs fine up to the point of installing grub, which gives a fatal error, and none of the recovery options seem to work, including “ignore”.


I have booted to the 16.04 live CD, run GParted, and wiped out every partition, but still get the same error. GParted did also report a warning, which I neglected to write down, something to the effect that the signature does not match, but allowed me to ignore and continue.


Any ideas on how to completely wipe the drives so I can do a fresh install?





Philadelphia Linux Users Group         --
Announcements -
General Discussion  --
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --