JP Vossen via plug on 7 Apr 2020 20:24:38 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Fixing /boot/ too small

Summary: I need to fix some Mint-19 workstations where /boot/ is too small.

Solution: below but needs sanity check.


I have some workstations I installed a long time ago and /boot/ is now too small. 200M was fine when I built them, but not anymore. I did a hacked RAID-1 mdadm install because whatever installer (Ubuntu or Mint) didn't do RAID, but I didn't do LVM. I've never had to re-install because...RAID-1! I've replaced all the disks over the years by swapping over to bigger ones, re-mirroring, and growing /.

The too small /boot/ is now causing a lot of problems because every time I run OS updates that want `update-initramfs` it fails due to lack of space, which fails the update, which fails the Ansible task. And then I am sad.

Fix: All the disk space is allocated, and they are not using LVM anyway, so I can't just make /boot/ bigger. (Well, if I was swapping to bigger disks I probably could, but that's not soon enough.) But I *CAN* just move /boot/ from its own md device and partition into '/' where it probably should have been in the first place. I'd then be wasting the old /boot/ space, but I can live with that or find something else to put in there. Maybe make it /tmp/.

I've done the following process on a sacrificial Mint-19 VM and rebooted and it Just Worked. BUT that VM was not running mdadm because I didn't feel like hacking the install again. I've also done the *process* on 2 of the workstations, but not *rebooted* yet. One node is 1.5 hours away in NJ...

On one hand, this is a very simple and straightforward process, even with mdadm in the mix. OTOH, GRUB and the boot process are subtle and quick to anger.


sudo -s
cp -a /boot /
mkdir /boot.old
touch / /boot.old/z-boot.old /boot/z-boot.orig
	# So I know what used to be where
vi /etc/fstab
	# To change the mount for /boot/ to /boot.old/
umount /boot
rmdir /boot
mv / /boot
update-initramfs -u -k all
### reboot?!?

Sanity check or clues for anything that might bite me?

--  -------------------------------------------------------------------
JP Vossen, CISSP | |
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --