[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Umbunto Not Updating & Firefox Not Working

Wow ... now Google Groups (or this one or this configuration thereof)
changes the From: header, and doesn't include a Sender: or Reply-to: header or
the like with the original From ... coerces everything to be sent to
the list.  Okay, sure, buried in some X- headers, but otherwise
hidden / "gone" / inaccessible to most.  So, for mail clients,
reply to list, reply to sender ... all goes to same email address (or,
egad, https URL that Google sticks in there - but I digress).

From: "'Christian Peeples' via BerkeleyLUG" <berkeleylug@googlegroups.com>
Subject: Umbunto Not Updating & Firefox Not Working
Date: Tue, 13 Sep 2016 00:56:52 +0000 (UTC)

I presume you mean Ubuntu ... looks like you're having bit 'o typing
difficulty. *buntu 14.4?  No such release, perhaps you meant 14.04?
14.04 is LTS, Ubuntu 14.04 is supported until ... 2019-04:
Not to be confused with *.4 releases/updates, such as 10.04.4, 12.04.4, 14.04.4,

Hope you'll be out of hospital and feeling much better, and soon!

Libre Office ... if it's misbehaving that much, yes, might be best to
uninstall and reinstall it - Libre Office, that is.  Using the appropriate
software package manager, of course.  And probably also "purge" it - which
then also removes the related configuration files - before reinstalling it.

I gave up using my Ubunto laptop because Libre Office Writer was corrupted and I could not fix it. I am going into the hospital and need it, so I thought I would try again. It booted into 14.4, but when I go to the Ubuntu Software Center, it shows my programs, but does nothing. The little fan gauge at the top shows that I am hoked to WiFi and have an adequate signal. I tried searching for "update" and "update all," but got no relevant hits. What am I doing wrong?

Network connectivity ... general troubleshooting - divide and conquer.
If you think you're more-or-less connected to Wi-Fi ... or attempting
to do so, probably a good place to start is see if you can ping the
default router.

You can use:
$ ip r s
to show routing information, or for just IPv4:
$ ip -4 r s
... presuming one has the ip command, if not, use:
$ netstat -nr
Anyway, with one of those commands, should see something like one of these lines:
default via [some_IPv4_address] dev [some_device] [...]
default via [some_IPv6_address] dev [some_device] [...] [some_IPv4_address] ...
One can then try and ping the IP address, e.g.:
$ ping -n some_IPv4_address
$ ping6 -n some_IPv6_address
Where one would use appropriate address obtained from the ip or netstat command earlier.
If that pings okay, one has IP connectivity.
Next would be DNS resolution, try and look up an Internet DNS name, e.g.:
$ dig +noall +answer www.google.com. A www.google.com. AAAA
www.google.com.         300     IN      A
www.google.com.         300     IN      AAAA    2607:f8b0:4007:800::2004

Then try reaching some stuff on The Internet - if DNS appears to be
working okay.  Note however, many Wi-Fi setups, e.g. cafe' and other
public places and such, may have a "click through" agreement/notice
page or the like - and will give about zero real Internet coverage
until one clicks through such.  In such case, point browser at most
anything on The Internet using http and port 80, e.g.:
And they'll generally redirect that to their "click through" page (or
if that's not needed, Goggle will redirect you to https).

Anyway, you'll generally need to get those bits working first,
before installing/updating software.

Once network+Inernet+DNS basically works fine, then you should be able
to update and (re)install software.  With an Ubuntu 14.04 (LTS) release,
one has two general options - continue updates along the
14.04.x line, and with their security updates, etc.,
or upgrade to later LTS: 16.04[.x] LTS line - but I think that latter
is probably not the default, and one would likely need to click through some
stuff or possibly take other explicit action to go from 14.04[.x] to
16.04[.x] - which would be a supported but relatively major upgrade.
There are some other options, but probably best to stick with LTS if
that's where one already is, and one wants to avoid rockier and more frequent
upgrades and less support for shorter periods of time.

With Ubuntu, one can use CLI programs apt-get and/or aptitude - I don't recall
what Ubuntu provides and/or prefers.  I know with current Debian it's apt-get,
and Ubuntu is based upon Debian, but Ubuntu doesn't always make the same choices.
The Libre Office packages typically have names staring with ... let's see ...
libreoffice ...
current Debian stable, I find ...
$ dpkg -l | awk '{print $2;}' | grep '^libreoffice'
So ... if one first confirmed such command gave only and exactly all the
desired packages one wanted to purge and reinstall ...
Could first save that list to a file, e.g. :
$ pkg -l | awk '{print $2;}' | grep '^libreoffice' > l.o.packages
And then purge them ... though one might want slightly different
command for Ubuntu, but on Debian, that would then be:
# apt-get purge $(cat l.o.packages)
Where we'd earlier saved list of packages to aptly named file.
And to reinstall - I'd guess the libreoffice package is probably
a meta-package that brings all the others in ...
$ apt-cache show libreoffice
... yes, on Debian, looking that information over, that is the
case (clearly seen in the Depends: - how it brings in the other libreoffice
So, could probably then just reinstall with something like:
# apt-get install libreoffice

Oh, also, before you start updating/installing software, if you're doing it from
CLI, will want to first do:
# apt-get update
... that updates the information of what versions of what packages are available, information about security updates, etc. Again, that may be a wee bit different
for Unbuntu from CLI - perhaps Ubuntu expert will chime in to address that.

And, if you've some time to fill in in hospital (can be pretty boring place!),
maybe ask folks for some phone number(s) so you can call 'em if you need assistance on some 'o this stuff ... depending how your connectivity is goin' (or not going)
in hospital, may be much more feasible to get some or much 'o that sorted out
with a live interactive phone call or two or so, rather than a series of
back-and-forth emails or list postings ... well, at least / especially if
you get stuck and can't post to / read from list.  You can then always
post a nice summary to list on your findings and what was done to fix
it once it's all sorted out - at least if you can't post at any point
along the way and get some assistance via phone ... that way others
also get a chance to read it on the list and learn/benefit from that too.

Best wishes on you and your Ubuntu configuration getting well soon!

Firefox opens nicely, but then can't find anything. I tried searching for "yahoo.com" and google.com" and all I get is that it can't find the server. Again, what am I doing wrong.

With LibreOffice Writer, the top bar (with "files," "home," "insert," etc. is missing. I assume the way to deal with that is to delete all of LibreOffice and reinstall from the depository, but I can't get to the depository. Again, what am I doing wrong?.

-- Chris Peeples --

You received this message because you are subscribed to the Google Groups "BerkeleyLUG" group.
To unsubscribe from this group and stop receiving emails from it, send an email to berkeleylug+unsubscribe@googlegroups.com.
To post to this group, send email to berkeleylug@googlegroups.com.
Visit this group at https://groups.google.com/group/berkeleylug.
For more options, visit https://groups.google.com/d/optout.