Pete Foley on Tue, 30 Jan 2001 09:37:12 -0500

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Odd CRC file errors and md5 checksum mismatches - Any ideas?

Well, I did some tests with the system memory, and I think I have found some of the problems.  After removing 2 Simms I can now successfully and consistently generate MD5 sums.  I also re-ran rsync on my Debian Potato image and it finally worked.  I still need to look into the network stuff though.  I copied an ISO from the server to my local box and the MD5 was different.  But this was also done at a time when another system was d/l rather heavily and another was coping a different ISO from the server - so there was a lot of traffic at the time.  I then ran rsync on that ISO and it was then fixed.

So I am going to look into the network some more to see if CRC errors happen when doing large copies.  Is there any way that I can force the network to do CRC checks on all transfers - and if any errors occur to auto-magically fix them?  If I could implement that my problems will be solved.

Also, I am not a huge network guru so I don't know if this is an issue or not, but I have noticed that even when there is no other network traffic, when I make large network copies, the collision light on my hub starts to blink.  Is that normal? If not can it be corrected?  The hub that I am using is a Linksys 5 port hub.

Thanks again for the suggestions... Looks like I am getting there...


Thus spake Pete Foley on Tue, Aug 29, 2000 at 10:53:44PM +0000:
> Well, Like I said I do not believe it is the network, because the other machines are fine.  And that box that is having problems is also a gateway, so all traffic basically goes through there.  I am thinking that it may be hardware.  The HD is fine ((I think).  It is a pretty new Maxtor drive, and I had it in another box a few months ago.  I don't know if this is on target at all, but I think it may have to do with transfer rate.  Initially, I had 2 HDs on the same IDE port.  The 1st one (a 3.6 gig Western Digital - the drive that the OS is on) as primary and the Maxtor as slave.  I ran same tests and found that the transfer rate on the 1st was at about 6mb/s and only 2mb/s for the 2nd.  So I moved the Maxtor to be the master on th 2nd IDE port, and played with the hard drive config tool (i forget what it is called) and got it up to 6mb/s.  That seemed to lower the errors, but obviously not completely.  The system is a 233 AMD w/ 64 RAM.  Could the system be working faster!
>  han the HD's can write? (Note that this problem does occur on both HDs.)  I was thinking about getting a Promise UDMA66 controller card to speed things up more and to see if that helps.
> I will mess with the memory a bit and see if that is the cause.  Is there an way that I can definitely rule out the network?  I don't want to have to buy some expensive line tester though.
> Thanks again!
> -Pete
> Thus spake Stephen Brown on Tue, Aug 29, 2000 at 05:36:46PM -0400:
> > Pete Foley wrote:
> > > I am having a very odd problem that I am unable to solve.  I have a box setup at home which is a file-print server, running woody.  When I try to copy large files to it, the files tend to get CRC errors.  So at first I thought it was my network, so I did some testing.  I made a CD image, and rar'ed it into about 50 rars.  Then tried to uncompress them.  I had to run the process several times before it finally worked - every time I ran it a different file would fail with a CRC error.  But when I would run it again, the initial erratic file would uncompress fine but another would then break.
> > 
> > I would suspect ethernet cables, any hub/switches in the network,
> > memory, and disks in that order. 
> > The few times I have had wacky errors along those lines it has been
> > the memory was dying, or the disk was dying. Memory is easy to
> > check by taking it to a computer store and asking nice for them
> > to test it for you (just be sure you can see them test it
> > and read the output on the tester's screen). If the disk is dying
> > I usually start to see IO errors in dmesg or /var/log/* a few
> > weeks before things get really bad - I had an IDE disk die on
> > me last week :( - but Linux is good about trying again and
> > plodding through the random errors until the disk totally dies.
> > Have you tried just shutting the box down for an hour, let it
> > cool to room temp, and then try your huge file copy right at 
> > startup?
> > 
> > Hopefully it is something easy to fix - good luck with it!
> > -- 
> > Stephen Brown                             Data Clarity, Inc. 
> >    tel:(877)496-3527 fax:(801)382-1525
> > 
> > 
> > ______________________________________________________________________
> > Philadelphia Linux Users Group       -
> > Announcements-
> > General Discussion  -
> > 
> > 
> ______________________________________________________________________
> Philadelphia Linux Users Group       -
> Announcements-
> General Discussion  -

Philadelphia Linux Users Group       -
General Discussion  -