Jon Nelson on Thu, 18 Oct 2001 19:10:11 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Trouble w/ procmail

Ok, I'm done pulling out my hair.  I am trying to get procmail to work on my
system.  I am running RH 7.1 with Postfix as my MTA, mutt, and this is a stand alone machine using a dial-up.  

I have a .procmailrc file.  I've tried it with/without a .forward file.
procmail is set up as the local mail handler in the /etc/procmail/
Everything I have read says that it should work.  I have checked that my home
dir and all the files have the proper permissions.

Mail is not being filtered into the proper mailboxes, and even though I have
verbose logging on there are no logs created.  This leads me to beleive that
procmail is not ever being run.  I grepped /var/log/ for any instance of
procmail with no luck. Other than that mail work great.

I ran "strace -o error procmail" and then looked through the log.  The only
thing I could find that seemed like an error was
"connect(3,{sin_family=AF_UNIX, path="/var/run/.nscd_socket"}, 110) = -1
ENOENT (No such file or directory)".

Any and all help would be greatly appreciated,


Philadelphia Linux Users Group       -
General Discussion  -