Fred K Ollinger on Sun, 6 Jul 2003 08:34:05 -0400

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Accessing a FAT32 drive from Linux

You could either download this:

All drives that could possibly be mounted under linux will probably show
up on kde desktop.

Cli mode is this:

1. fdisk -l

This will show you your partition tables. You will see the type as well.

2. Next you can mount it:

mount -t msdos /dev/hdb1 /mnt

This will mount the first partition from the first slave drive onto /mnt.
You can take it from there. If you need more mount points, do this:

mkdir -p /one

for example.

Fred Ollinger (
CCN sysadmin

On Wed, 25 Jun 2003, Stephen Gran wrote:

> On Wed, Jun 25, 2003 at 06:38:56PM -0400, George Langford said:
> > Hello Plug !
> >
> > Here's some more information.
> >
> > The BookPC's BIOS is perfectly happy with both the 40GB and 80GB
> > Maxtor drives on the same cable - The 80GB's in the middle as
> > Slave and the 40GB's at the end as Master.
> That's a good start - if the BIOS is happy with the drives and finds
> them during the IDE scan at boot time, linux should be able to handle
> them, if they aren't completely hosed.
> > What I'm discovering is that Red Hat Linux chokes when it tries to
> > detect the 80GB drive - and there's no opportunity to mount it along
> > with the floppy drive when I right-click on the display [desktop ?].
> > I need to work out a command-line syntax to tell Linux what file
> > system to look for. That's when I get all glassy-eyed.
> (as root): mount -t vfat /dev/hdb1 /mnt (I'm assuming you only have one
> partition on your drive, and it is the slave on the first IDE cable)
> > Thanks to Jeff for helping me decide that the W98SE/WinXP mess
> > wasn't worth saving.  None of the participants here, on Experts-X,
> > or anywhere else on the 'Net ever solved the sorts of error
> > messages that I was getting - Hall.dll hosed; fdisk giving me
> > the rong disk size, proprietary file system.  Heck, I even tried
> > deleting the Windows directory from the other 80GB drive - it
> > let me try & went through the motions, but it was all still there
> > to get in the way of a W98SE reinstall after all was said and done.
> Good luck fixing a severely broken Win98 install - I've never succeeded
> with anything short of burnt-earth approaches.  'deltree' from real DOS
> - not the sorta DOS shell that you can get from within Windows - will
> usually do it, but Windows won't let you.
> Good luck, and HTH,
> --
>  --------------------------------------------------------------------------
> |  Stephen Gran                  | In the future, you're going to get      |
> |             | computers as prizes in breakfast        |
> | | cereals. You'll throw them out because  |
> |  			         | your house will be littered with them.  |
>  --------------------------------------------------------------------------
Philadelphia Linux Users Group        --
Announcements -
General Discussion  --