Stephen Gran on 16 May 2005 22:38:04 -0000

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]


On Mon, May 16, 2005 at 04:34:11PM -0400, said:
> Hi all, potentially dumb question.
> I installed FC3 on a older box (AMD 500mhz) with the plan of making it a 
> file server that shares a 20gb drive on my private network. Most of the 
> machines on my network are XP.
> I configured Samba the same way as my other linux box (RedHat 9) and 
> everything appears to work when you click on Network Neighborhood, but 
> attempting to view the shares on the 500mhz (VAULT is the hostname and the 
> netbiosname) I get resource unavialable errors. I tried a few things and I 
> noticed that when I try to browse by IP address (by typing \\ 
> it works fine, but when I type \\VAULT it just can't resolve the name to 
> IP. On my Redhat 9 box (FServ) it works just fine.
> So on FServ I type "nmblookup fserv" and get the proper address. The 
> confusing part is that on vault I type "nmblookup vault" and it can't find 
> it! How does vault not know his own address?!?
> I've been fighting with this and even tried upgrading to a newer version 
> of Samba, all with the same results. the necessary ports for samba 
> (including 445) are open on my private network (All behind a firewall 
> which blocks just about every port from the outside world). When I do an 
> nmblookup by IP Address I see VAULT just fine (3 entries for it, actually, 
> and 2 for my workgroup... is that normal?) and when I try and access 
> shares by IP address it works fine... when I try to access shares by name 
> it all just barfs... nothing in the error logs or anything. Vault is 
> announcing itself to the network, but for some reason it's not announcing 
> it's IP as well...
> I'm about to just wipe it and install RH9 on it since that actually seems 
> to WORK on my other box... Any ideas before I try rolling back to RH9? I 
> really would prefer to use something not so old, but if it works and FC3 
> won't, well then it won't upset me much. I suppose I could try a different 
> distro, but I just don't have the desire to spend all of my time fidgeting 
> with new versions of this and that after working as a programmer all 
> day... I just want something that works with a little effort on my part, 
> but not a herculean effort, if you know what i mean...

Doesn't winbind take care of the nsswitch stuff for the samba side of
things?  Probably that is not running, or is not in /etc/nsswitch.conf
|  Stephen Gran                  | Misery loves company, but company does  |
|             | not reciprocate.                        |
| |                                         |

Attachment: pgpRnTpsVB94T.pgp
Description: PGP signature

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --