Stephen Gran on 14 Jan 2006 12:07:45 -0000

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] BIOS EDD -- new install hangs

On Fri, Jan 13, 2006 at 09:27:08PM -0500, Christopher M. Jones said:
> I'm trying to install linux on an older machine (Celeron 700 vintage).
> I've tried several distros: ubuntu, debian, Mandrake. All of them have
> the same result: they hang after ACPI reports its wake devices and EDD
> reports devices. The last line before a hang reads thus:
> ACPI: (supports S0 S1 S3 S5)
> BIOS EDD facility v0.16 2004-Jun-25, 6 devices found
> After that, nothing.
> Board is a SuperMicro 810 with Amibios 1997 1005001460 R 1.2C
> I don't know what kernel version it's trying to install, since the
> messages go by so fast, but surely its the 2.6 series. By the way, an
> older Mandrake, 10.1 community, did boot on this machine at one time.
> Any ideas? I'm not even sure what to google.

The bit that happens right after those two lines is usually the IDE
layer probing, so it may be that that's what's failing.  BIOS EDD was an
attempt to have a uniform way for the BIOS to tell the OS what disk to
boot from, among other things, but it doesn't always work out, or at
least that was my impression.  Can you try shutting off EDD in the BIOS?
Or maybe on the kernel command line?

Good luck,
|  Stephen Gran                  | The graveyards are full of              |
|             | indispensable men.   -- Charles de      |
| | Gaulle                                  |

Attachment: signature.asc
Description: Digital signature

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --