schwepes on 21 Jan 2006 15:51:09 -0000

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] ASCII files

On Thu, 19 Jan 2006, Douglas Muth wrote:

> On 1/19/06, <> wrote:
> > This is a modest problem but extremely frustrating.
> > For years, and from the name of the program, some of you will guess how
> > many years, I have used Multimate as a word processor.  This was a DOS
> > program by the same folks that brought you DBASE.  I converted files
> > from that to ASCII.txt and then tried to use them in a Linux environment,
> > Suse to be precise, and mtype refuses to read the whole file.  It drops
> > in the middle of a line where there should be no bizarre characters to
> > be read.  Mcopy gives an error messege when I try to invoke it.
> > I really want to be able to trash the machine and gain the workspace but
> > I don't want to waste time typing everything out again in vi or gnu.
> Can you paste here the exact error message that you got from Mcopy?
> Also, could you try running the "file" command on one of these ASCII
> files?

plain_io: Input/output error
file read: Input/output error

I also tried mread -t to the same effect.
> If memory serves, MS-DOS files have lines that end with a carraige
> return character (CR) followed by a linefeed character (LF).  In
> Linux/UNIX, lines are terminated with only a linefeed.  It is possible
> that the problems you are having are caused by incorrect line
> terminators.
> You may also want to see if your machine has the"dos2unix" utility on
> it, which converts MS-DOS text files to UNIX text files.

dos2unix did not ring any bells on the machine.

> -- Doug
> ___________________________________________________________________________
> Philadelphia Linux Users Group         --
> Announcements -
> General Discussion  --
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --