Douglas Lentz on 17 Apr 2006 00:24:46 -0000

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Creating DVD images via transcode, mystery error

Hi, all. I am attempting to create a DVD playable is a standard NTSC DVD player, from an .mpg file. I am following the instructions on the transcode_wiki (, and if anyone has ever looked at this page, it (1) lists all the dependencies required, and (2) the transcode command line needed to create the .ac3 file from your .mpg or .avi, followed by (3), a whole load of other stuff.

I have completed (1). All dependencies have been built from source on my box, no binaries, rpms, etc were used.

When I run (2), transcode stops dead and reports " cannot open shared object file: No such file or directory". The wiki states in the first paragraph that libavcodec is an absolute necessity. I investigated. libavcodec.s0.51 lives happily in /usr/local/lib as a symbolic link pointing to the most recent version of libavcodec, which is When I saw this error, two thoughts flashed through my mind:

a) transcode could not find libavcodec in /usr/local/lib
b) transcode could not follow a symbolic link.

But, I find both of these things hard to believe. I set a path to /usr/local/lib in shell var LD_LIBRARY_PATH. That did absolutely nothing at all. I replaced the symlink with a copy of No luck, same error message. I googled the error message and got nothing back.

I have never seen anything like this before. Something is going on that I don't understand. Does anyone have an idea what?

Alternatively, is the way that I'm trying to make a DVD crazy, and does anyone have another suggestion?

Thanks, everyone.

___________________________________________________________________________ Philadelphia Linux Users Group -- Announcements - General Discussion --