jazzman on 12 Sep 2006 03:53:44 -0000

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] OT: Odd CF Card Behavior...

Ok, this gets weirder and weirder...

I plugged the drive into my linux box and dmesg reports the following:

sda : READ CAPACITY failed.
sda : status = 1, message = 00, host = 0, driver = 08
Info fld=0xa00 (nonstd), Current sd00:00: sense key Not Ready
sda : block size assumed to be 512 bytes, disk size 1GB.
 sda: I/O error: dev 08:00, sector 0
 I/O error: dev 08:00, sector 0
 unable to read partition table
hub.c: new USB device 00:1d.2-2, assigned address 3
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 3
SCSI device sda: 1001952 512-byte hdwr sectors (513 MB)
sda: Write Protect is off
 sda: sda1 sda2

So I went into FDISK and attempted to verify the partition table and got 
the following:

Partition 1 has different physical/logical beginnings (non-Linux?):
     phys=(0, 1, 1) logical=(0, 1, 2)
Partition 1 has different physical/logical endings:
     phys=(1, 254, 63) logical=(32, 6, 14)
Partition 1 does not end on cylinder boundary.
Partition 1: head 255 greater than maximum 16
Partition 1: sector 63 greater than maximum 62
Partition 1: previous sectors 32129 disagrees with total 2238
Partition 2 has different physical/logical beginnings (non-Linux?):
     phys=(2, 0, 1) logical=(32, 6, 15)
Partition 2 has different physical/logical endings:
     phys=(62, 93, 63) logical=(1010, 0, 32)
Partition 2 does not end on cylinder boundary.
Partition 2: head 94 greater than maximum 16
Partition 2: sector 63 greater than maximum 62
Partition 2: previous sectors 1001951 disagrees with total 62589
30 unallocated sectors

It looks to me like the partition table got all screwy. But yet windows 
reports the drive as one partition in "My Computer", though it shows TWO 
partitions in Drive Manager. It's SUPPOSED to be one big fat partition. 
The CAMERA seems to ignore the partition table and just read directly I 
guess, not that that makes any sense to me, but I just got back from 
driving across the state after helping a friend watch her 3 year old 
daughter all weekend so my brain isn't working well.

Does anyone know how to correct this so the OS sees ONE partition liek 
it's supposed to and do it WITHOUT destroying the data on the drive... i 
kinda need the files...  Anyone know of any ways (using dd I think it 
can be done but I"m terrible with dd. Any help would be REALLY 
appreciated) to get the data off safely? Once it's off I can zero out the 
ENTIRE card and start over... I can't tell if the card is dying or if the 
partition table is all screwy, thus causing many many problems...

THanks for the continued help, all :)

On Sun, 10 Sep 2006, Jeff Abrahamson wrote:

> If you have a USB CF card reader, then linux will think the card is an
> IDE drive, so you can do all the fun things you like with IDE drives:
> dd, etc.
> That said, watch kern.log.  The one time I had a problem like this,
> the card was failing.  I eventually got everything off, but a few pics
> were touch and go for a while.  I just tried to mv the files until it
> finally worked.  Also, some card readers are sometimes more tolerant
> than others.  Your camera is probably reading a thumbnail rather than
> the whole image, so it's ok because it's doing something that's stored
> on different blocks.
> To confirm the card's health, after all the data you care about is
> recovered, do a low-level format with "mkfs -c".  RTFM for details,
> there are lots, but a vanilla "mkfs -c /dev/sdc" (use the right
> device) is a good first approximation.  Watch syslog for the device
> info and for any errors.  (Errors will go to kern.log, also, if syslog
> is too active on your machine.)
> HTH.  Good luck.

Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug