Matt Mossholder on 1 Jan 2008 13:05:25 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] More SAMBA fun

On Tue, 2008-01-01 at 14:56 -0600, Adam J. Zion wrote:
> Another Frankenputer, another distro, another Samba problem. Joy.
> OK, here's the deal. I put together a new PC + loaded gOS (Ubuntu-based), as it appears to be a good choice for a lower-end PC. So far, so good- it detected all my printers, my scanner, etc., + the performance is fine. The problem is that I can't get it to mount my linux server's Samba shares.
> I'm about 99.9% sure that the problem is not on the server, since I can still access the shares from my Windows + OS X boxen. But I can't mount them from the new linux box. Note: I am able to print to the CUPS printers, shared off the same server, perfectly well from the new PC.
> Here's the command I run to make the mount. This is the same command that I previously used to mount from Freespire (another Ubuntu-based distro) + Mandriva:
> sudo mount -t smbfs //calvin/adam /media/adam -o uid=adam,gid=users
> Here's the response:
> 9740: tree connect failed: ERRDOS - ERRnoaccess (Access denied.)
> SMB connection failed
> The number at the beginning of this line is different every time I run the command.
> Here's the really odd part: I can access this particular share via smbclient:
> smbclient //calvin/adam -U adam
> Thoughts?
> -Z

	The uid and gid params to mount for smbfs specify the local user and
group to permit access to the share. You need to pass in a username= and
password= parameters to specify the the credentials to use when
accessing the share.


Philadelphia Linux Users Group         --
Announcements -
General Discussion  --