Brian Stempin on 15 Jan 2008 16:36:25 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Xen Kernel Installation in Ubuntu 7.10

Hello everyone,

I recently installed Ubuntu 7.10 on a machine to use for playing with Xen using the Ubuntu alternative install CD.  The only thing out-of-the-ordinary that I did with the installation has to do with my partitioning.  I've taken 2 SATA drives and created 2 raid devices:  /dev/md0 is a RAID1 of /dev/sda1 and /dev/sdb1, and /dev/md1 is a RAID0 of /dev/sda2 and /dev/sdb2.  /dev/md0 contains / and /dev/md1 is mounted as /media/storage.

After the installation, I ran "sudo apt-get install ubuntu-xen-server".  Everything went well, but my machine didn't boot up the new Xen kernel.  All of the guides involving Debian/Ubuntu and Xen involved using GRUB as a bootloader.  In my case, I'm using LILO, so I decided to take a stab in the dark at it.  Below is my /etc/lilo.conf file.  The good news:  /vmlinuz is a symlink to the kernel containing the Xen extensions.  The bad news:  whenever I run "sudo lilo -v 2", I get this output:

bstempi@xen01:/$ sudo lilo -v 2
[sudo] password for bstempi:
LILO version 22.8, Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2006 John Coffman
Released 19-Feb-2007, and compiled at 11:30:30 on Aug 10 2007
Running Linux kernel 2.6.22-14-generic on i686

Warning: LBA32 addressing assumed
Warning: '/proc/partitions' does not match '/dev' directory structure.
    Name change: '/dev/dm-0' -> '/dev/xen01-1/storage'
Warning: Name change: '/dev/dm-1' -> '/dev/xen01-0/swap'
Warning: Name change: '/dev/dm-2' -> '/dev/xen01-0/root'
pf_hard_disk_scan: ndevs=2
  0800  3FC43FC3  /dev/sda
  0810  2DAEF1F2  /dev/sdb
device codes (user assigned pf) = 0
device codes (user assigned) = 0
device codes (BIOS assigned) = 3
device codes (canonical) = 3
RAID info:  nr=2, raid=2, active=2, working=2, failed=0, spare=0
Using BIOS device code 0x80 for RAID boot blocks
raid_setup returns offset = 00000000  ndisk = 2
 BIOS   VolumeID   Device
  80    2DAEF1F2    0810
  81    3FC43FC3    0800
raid flags: at bsect_open  0x02
Reading boot sector from /dev/md0
map_create:  boot=0900  map=FE02
mode = 0x03,  columns = 80,  rows = 25,  page = 0
Using MENU secondary loader
Calling map_insert_data
Secondary loader: 18 sectors (0x3600 dataend).
bios_boot = 0x80  bios_map = 0x80  map==boot = 0  map S/N: 00000000
BIOS data check was okay on the last boot

Boot image: /vmlinuz -> /boot/vmlinuz-2.6.22-14-xen
Setup length is 28 sectors.
Fatal: Kernel /vmlinuz is too big
Removed temporary file /boot/map~

I know next to nothing about boot images, etc.  Any ideas?


# /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
# ---------------       `install-mbr(8)', `/usr/share/doc/lilo/',
#                       and `/usr/share/doc/mbr/'.

# +---------------------------------------------------------------+
# |                        !! Reminder !!                         |
# |                                                               |
# | Don't forget to run `lilo' after you make changes to this     |
# | conffile, `/boot/bootmess.txt' (if you have created it), or   |
# | install a new kernel.  The computer will most likely fail to  |
# | boot if a kernel-image post-install script or you don't       |
# | remember to run `lilo'.                                       |
# |                                                               |
# +---------------------------------------------------------------+

# Specifies the boot device.  This is where Lilo installs its boot
# block.  It can be either a partition, or the raw device, in which
# case it installs in the MBR, and will overwrite the current MBR.

# Specifies the device that should be mounted as root. (`/')

# Specifies the device that should be mounted as root. (`/')

# This option may be needed for some software RAID installs.

# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller.  Using `compact' is especially recommended when
# booting from a floppy disk.  It is disabled here by default
# because it doesn't always work.
# compact

# Installs the specified file as the new boot sector
# You have the choice between: text, bmp, and menu
# Look in lilo.conf(5) manpage for details

# Specifies the location of the map file

# You can set a password here, and uncomment the `restricted' lines
# in the image definitions below to make it so that a password must
# be typed to boot anything but a default configuration.  If a
# command line is given, other than one specified by an `append'
# statement in `lilo.conf', the password will be required, but a
# standard default boot will not require one.
# This will, for instance, prevent anyone with access to the
# console from booting with something like `Linux init=/bin/sh',
# and thus becoming `root' without proper authorization.
# Note that if you really need this type of security, you will
# likely also want to use `install-mbr' to reconfigure the MBR
# program, as well as set up your BIOS to disallow booting from
# removable disk or CD-ROM, then put a password on getting into the
# BIOS configuration as well.  Please RTFM `install-mbr(8)'.
# password=tatercounter2000

# Specifies the number of deciseconds (0.1 seconds) LILO should
# wait before booting the first image.

# You can put a customized boot message up if you like.  If you use
# `prompt', and this computer may need to reboot unattended, you
# must specify a `timeout', or it will sit there forever waiting
# for a keypress.  `single-key' goes with the `alias' lines in the
# `image' configurations below.  eg: You can press `1' to boot
# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
# message=/boot/bootmess.txt
#       prompt
#       delay=100
#       timeout=100

# Specifies the VGA text mode at boot time. (normal, extended, ask, <mode>)
# vga=ask
# vga=9

# Kernel command line options that apply to all installed images go
# here.  See: The `boot-prompt-HOWTO' and `kernel-parameters.txt' in
# the Linux kernel `Documentation' directory.
# append=""

# If you used a serial console to install Ubuntu, this option should be
# enabled by default.
# serial=

# Boot up Linux by default.

#       restricted
#       alias=1
        append="root=/dev/mapper/xen01--0-root  "

#       restricted
#       alias=2
        append="root=/dev/mapper/xen01--0-root  "

# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
# other=/dev/hda4
#       label=HURD
#       restricted
#       alias=3

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --