Art Alexion on 13 May 2008 07:18:57 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] salvaging an ubuntu upgrade

Long story short:

Doing a gutsy->hardy upgrade on a laptop using the do-release-upgrade command 
that worked so well on other machines.  Power went out.  Battery was charged.  
Packages had been downloaded. Installation continued.  But...

When I picked up the laptop to move it, the battery fell out.  Never mind that 
I can never get this battery out when I need to.  This critical time, it just 
fell out.

re-running do-release-upgrade didn't work because it thought it was already 
upgraded to hardy.  aptitude dist-upgrade failed, suggesting 
dpkg --configure -a.  This worked until it got to kde-theme-somethingorother.
aptitude install kde-theme-somethingorother wanted to remove about 22 
packages.  I listed them and let it. Then ran an aptitude dist-upgrade.

Everything looks fine, except one thing.

Whenever I try to run anything as sudo it hestiates, then reports 
sudo: unable to resolve host <localhostname>

/etc/hostname is correct
the networkmanager seems to have the host correctly.

What would I edit to fix this?

Attachment: signature.asc
Description: This is a digitally signed message part.

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --