Art Alexion on 3 Jul 2008 09:47:18 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] 16 GB USB stick

We got a bunch of these at work and Linux wouldn't automount them.  Manually 
mounting with user permissions was a pain.  Thanks to a suggestion from Jim 
Barrett, I repartioned and recreated the FS (fat32).  That fixed the problem, 
so if you get one of these with the mounting problem try it.

In partitioning, I diagnosed the problem.  The sectors were non-standard 1096.  
cfdsk refused to deal with the stick.  I used the older fdisk which reported 
the problem and allowed me to delete the partition.  Repartitioned in cfdsk.  

I tried to use an XP command line to format as NTFS (for 
cross-compaitibility), as the linux mkfs.ntfs doesn't exist.  Turns out the 
windows format command won't create an ntfs file system on a removeable 
drive, anyway.  So I formatted as fat32.

Popped it i Gnome, and bam, Nautilus pops up with it.  Jammed it into KDE and 
the KIO "what do you want to do?" box opened.  

Problem solved.  Apparently it was the non-standard sector size.

Hope someone finds this useful.

Attachment: signature.asc
Description: This is a digitally signed message part.

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --