Brian Vagnoni on 15 Oct 2008 20:33:38 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] VMWare/Disk Cache Exceeding Physical Memory

I'm trying install Windows 2008 Server x64 as a guest OS using VMware 6.5 Workstation x64 for Linux. I've tried using Opensuse 10.3 x64 and Opensuse 11.0 x64 same results. During the creation of the virtual disk my disk cache attempts to exceed my physical memory and crashes/locks the system.

2 x Dual Core Op 270's Tyan S2895 motherboard with 8gb of memory, Intel branded LSILogic PCI-X raid controller with 512mb of cache and a 250gb Raid 5 array. NVidia 260 GTX PCI-e video card. 

It's a fresh install on an EXT 3 fs which is all allocated to one partition less the 2gb swap. 1Gb of ram is allocated to the VM along with a virtual disk of 24gb and it locks the system whether it is pre-allocated or not. Tried JFS much faster but same result. Tried external usb drive same result.

Host and Guest are both approved by VMWare to work.  

Tried playing around with swappiness no luck. Tried setting 2gb limit on all VM's under preferences in VMWare Workstation no luck. 

Is there anyway to ratio disk cache to physical memory so that it doesn't run the system out of memory. 


Philadelphia Linux Users Group         --
Announcements -
General Discussion  --