Brian Vagnoni on 21 Oct 2008 21:15:21 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] VMWare/Disk Cache Exceeding Physical Memory

The VMware mystery & saga ended tonight. I hate memory issues. Out of all computer
problems memory issues have got to be the worst.

Despite the fact that all my memory, good registered memory if you like Kingston had the same part number being KVR400S4R3/1G there were still issues. Surprise, surprise, surprise(in Gomer Pyle voice) you also have to check rev numbers. Those little white sticks at the other end of the DIMM. 

My motherboard has 4 banks of 2 DIMM's each totaling 8 slots. Each bank of 2 DIMM's have to be the same. But bank to bank can be different sizes and ranks as well as chips.

Found 3 DIMM's I couldn't match up. Same part number but the rev numbers are as follows:


The last 2 DIMM's listed above have different chips:

samsung 625
samsung 637

They also had different timing/buffer chips.
One by ICS
the other by TI

That's what I get for trying to get off cheap. Next time I'm spending the extra money and get them in matched pairs.

Memtest 2.01 finally had me look at the ram with a Microscope.

I'm just glad I finally found it. 

Brian Vagnoni
PGP Digital Fingerprint
F076 6EEE 06E5 BEEF EBBD  BD36 F29E 850D FC32 3955

----- Original Message -----
From: Brian Vagnoni
To: Philadelphia Linux User's Group
Discussion List []
Sent: Wed, 15 Oct
2008 23:33:30 -0400
Subject: [PLUG] VMWare/Disk Cache Exceeding
Physical Memory

> I'm trying install Windows 2008 Server x64 as a guest OS using VMware
> 6.5 Workstation x64 for Linux. I've tried using Opensuse 10.3 x64 and
> Opensuse 11.0 x64 same results. During the creation of the virtual
> disk my disk cache attempts to exceed my physical memory and
> crashes/locks the system.
> 2 x Dual Core Op 270's Tyan S2895 motherboard with 8gb of memory,
> Intel branded LSILogic PCI-X raid controller with 512mb of cache and a
> 250gb Raid 5 array. NVidia 260 GTX PCI-e video card. 
> It's a fresh install on an EXT 3 fs which is all allocated to one
> partition less the 2gb swap. 1Gb of ram is allocated to the VM along
> with a virtual disk of 24gb and it locks the system whether it is
> pre-allocated or not. Tried JFS much faster but same result. Tried
> external usb drive same result.
> Host and Guest are both approved by VMWare to work.  
> Tried playing around with swappiness no luck. Tried setting 2gb limit
> on all VM's under preferences in VMWare Workstation no luck. 
> Is there anyway to ratio disk cache to physical memory so that it
> doesn't run the system out of memory. 
> Thanks
> Brian
> ___________________________________________________________________________
> Philadelphia Linux Users Group         --       
> Announcements -
> General Discussion  --  
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --