edmond rodriguez on 26 Dec 2008 19:11:34 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] meeting followup: ndiswrapper working with 2.6 Kernel

ndiswrapper working on 2.6 kernel, though still many issues with wpa_supplicant (an entirely seperate issue):

For anyone interested in ndiswrapper issues with the 2.6 kernel, here are some things I worked on since the last meeting:

I had talked at a meeting about some problem with ndiswrapper and the 2.6 kernel.  ndiswrapper compiled and loaded, but no "blue light" (on my machine) and no other indications from typing commands that it was working.   I was able to resolve all the problems, though I may never get the wpa_supplicant to work (with or without WICD). 

I had trouble getting ndiswrapper and my Windows braodcom 4318 drives to work on my  2.6.24 kernel.

Learning at the meeting that Slackware recently made a new release to 12.2 and also seeing from this forum ( 


) that there may be minor issues with the 2.6.24 kernel working with ndiswrapper, I decided to upgrade regardless of if the forum was correct or not.  

Now with 2.6.27 kernel, ndiswrapper would no longer compile!

So I found another posting about fixes for the compile:


I ran recursive diffs to check on changes, then compiled and installed this fixed version. 

Still no "blue light" on my machine. 

Using the earlier forum above, I had to remove modules that were loaded at boot time:

rmmod b43
rmmod ssb

I don't recall now if there were any issues with the order in which I removed them.

Staring over with my Windows drivers newly loaded by my fixed ndiswrapper I could now "modprobe ndiswrapper", and finally, the blue light that indicates my wireless card is enabled comes on. 

I could scan the networks and connect to anything that is not secured.

Now I once had wpa_supplicant working on an older kernel for WPA TKIP, but at this time, after much frustration, not working!  I am trying to get it to work with WPA2 (TKIP or AES), as the configuation on my router indicates.   I learned about WICD, and that did not help after hours of tweaking it.

But that issue is independent of ndiswrapper.  If anyone knows of a very robust wpa interface, please do let me know. 

So the good news is, ndiswrapper is running and it is working on the 2.6 kernel.  


Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug