Douglas Lentz on 1 Apr 2009 14:23:05 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Mythbuntu Audio Troubleshooting

Hi - perhaps someone could lend me some assistance; since for me, sound 
"has always worked before" I'm uncertain about what to do next.

I have a new Mythbuntu 8.10 installation. The facts:

I installed Mythbuntu upstairs  where I have a network connection. I 
used a standard VGA monitor at installation time. No problems with 
installation. I sftp'd  some video files from my desktop computer to 
mythbuntu:/var/lib/mythtv/videos. They played fine using via the mythtv 
front end. For sound, I plugged a pair of headphones into one of the 
analog sound jacks on the box.

After I learned enough about the front end to demonstrate it to the 
family, I downed the box, unplugged the ethernet cable, and carried it 
downstairs to the the flat panel LCD TV. There is no network connection 
down there yet. Using an amazing expensive DVI to HDMI cable I plugged 
the box in to the LCD TV. I powered on the box. The box came up, the 
front end came up, but there is no sound. No sound via DVI/HDMI, no 
sound from the audio jacks. (Did mythbuntu detect that DVI output was in 
use and spontaneously reconfigured itself?).

Reconstructed the original configuration with the standard VGA monitor.  
Still no sound through the audio jacks.

My installation of Mythbuntu uses mplayer. mplayer says

Forced audio codec: mad
Opening audio decoder [libmad] libmad mpeg audio decoder
Audio 48000Hz 2ch.... (etc)

Selected audio codec [mad] afm: libmad
AO [pulse] Failed to connect to server. Connection refused.
AO [alsa] 48000Hz 2ch s16le (2 bytes per sample)

and then proceeds to play the video. The AO [pulse] line is the only 
thing that looks unusual.

According to the front end setup, my audio output device is 
alsa:default. The passthrough device is set to default. Mixer volume is 
set to 70%. Volume is up on the TV. The headphones work.

The audio controller is an nForce3 250Gb AC'97. The log grabber sees a 
VGA compatible controller, nVidia Geforce 6200 A-LE.

Action taken: sudo /sbin/alsa reload.

alsa reloaded, but no improvement. I do not see an "alsa" process 
running when I ps.

I browsed the error logs, but I don't see anything related to sound 
(that I recognize, at least). I googled "mythbuntu 8.10 no audio". I 
found a reference to an /etc/asound.conf. I do not have one. Someone 
else posted that "pulse" should not be configured in 8.10. I don't see 
"pulse" anywhere in setup.

Mostly, I would appreciate any suggestions on what else I should be 
looking for.

Thanks in advance, all!

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --