JP Vossen on 13 Apr 2009 14:00:12 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Jaunty on Mini-9

Over the weekend I installed Jaunty on my new Dell Mini-9.  So far, it 
went *really* well.  Interestingly, with many more packages installed 
than the stock Dell Ubuntu 8.04 image, I'm using a bit less disk (SSD) 
space.  I think Dell crufted up their stock image a bit (e.g., with a 
bunch of KDE apps in an otherwise Gnome image).

No networking worked during the install, but it was mostly fine after 
[1,2].  Everything else I've tried Just Works.  I don't have a web cam 
and have not tried a mic, but sound worked (seems rare for Dells on < 
Jaunty), hibernation works, etc.

Youtube flash still does not work out-of-the-box and I haven't bothered 
to fix it yet.

MythTV does work, even wireless(!), but I have only SD, no HD content.

Planet Penguin Racer and Stellarium both work fine.  By comparison they 
both totally crush my ancient Inspiron 7500 PIII.

I haven't tested battery life much yet, but I did use the Jaunty LPIA 
install and repo, so hopefully it won't matter much.

I am now running whole-disk encrypted and have not noticed any difference.

So far, I am very, very pleased.

[1] It didn't install the "linux-lpia" meta package, so I had to 
manually install linux-restricted-modules-lpia, which then gave me the 
"Broadcom STA wireless driver", see

[2] As just noted, Jaunty uses the sta instead of wl driver for the 
crappy Broadcom wireless card.  Both work, but are flaky with WPA (at 
least for me, with my FiOS Actiontec device), and the wl drive is buggy 
out of the box on the Dell stock 8.04 install:

HOWTO Details:
I'd previously tried the Jaunty UNR beta 
( via Live-USB.  It kinda 
sucked.  Touchpad scrolling didn't work, I hide the top panel and apps 
still left space, etc.  The UNR interface looked really cool, though I 
prefer the regular Gnome desktop and switched to it, which may account 
for some of the glitches.

So the only reason I was comfortable doing this is that I now have two 
SSD cards, so I yanked the stock 4G one but could trivially revert to if 
if needed.  But I'm very pleased and plan on sticking with Jaunty.

Note: the daily CD image I used does NOT use the "normal" repos, I have:
$ cat /etc/apt/sources.list
deb jaunty          main 
restricted universe multiverse
deb jaunty-updates  main 
restricted universe multiverse
deb jaunty-security main 
restricted universe multiverse

x Get Ubuntu 9.04 LPIA ISO
     x 2009-04-11 =
x "Burn" ISO to usb using Intrepid usb-creator
x Swap in new 16G SSD (seen as: 15.4G ATA Flash)
x Boot from USB and install
     # DHCP failed, even with wired connection = used "don't configure 
network for now"
     - Partitioned: Guided: entire, encrypted, LVM
         > /boot as ext2 outside LVM
         > It chose 'relatime' by default!
         > It only chose 687.9MB for swap, not enough to hibernate 2G RAM
         x Re-did like this:
LVM VG mini9, LV lv_root - 13.1 GB Linux device-mapper (linear)
       #1         13.1 GB       F ext3       /
LVM VG mini9, LV lv_swap_1 - 2.1 GB Linux device-mapper (linear)
       #1          2.1 GB       f swap       swap
Encrypted volume (sda1_crypt) - 15.2 GB Linux device-mapper (crypt)
       #1         15.2 GB       K   lvm
SCSI1 (0,0,0) (sda) - 15.4 GB ATA Flash Module
       #1  primary   15.2 GB    K   crypto   (sda1_crypt)
       #1  logical  255.0 MB    F   ext2     /boot
x Encrypted the drive during install (see above)
     >> *After* doing whole-disk, it asked if I wanted to "seamlessly" 
encrypt my /home/ dir.  I probably would have chosen that option!
x After install, hibernation worked (slow, as expected w/ 2G RAM and 
whole-disk encryption)
     + Stock install used 1.7G, 9.8G free
x Sound = Just Worked
x Wired NIC = Just Worked
x Wireless NIC (WPA) = not seen (modprob or "Hardware Drivers" GUI), 
does not work.
     + aptitude install linux-restricted-modules-lpia
     = Gave me the "Broadcom STA wireless driver" (proprietary, Tested 
by the Ubuntu Devs)
     = Worked *eventually* with WPA, took more tries and they took 
longer than the 8.04.1 wl driver
x Touchpad "scrolling" = worked (didn't work in UNR beta)
x Hidden top panel = worked (didn't work right in UNR beta, apps still 
left space for the panel)
x No SSH BUG with wl driver (since using sta) 
     = Not needed, well documented /etc/fstab using UUIDs

x Remove some cruft (much of this is from the stock Dell Mini-9 install; 
not all of it was in my Jaunty install, left here for reference):
     aptitude purge evolution evolution-common evolution-exchange 
evolution-indicator evolution-plugins evolution-webcal hpijs hplip 
hplip-data foomatic-db-hpijs brasero cdparanoia ekiga kalgebra kanagram 
khangman kmplot kolf ktouch kworldclock lmarbles wvdial tracker 
tracker-search-tool tracker-utils
x Install, a ton of apps:
     bash-completion bzip2 ca-certificates cron deborphan less 
localepurge logcheck logrotate lshw lsof mailx netcat nmap ntp 
nullmailer openssh-server patch pciutils psmisc procinfo rsync screen 
sshfs subversion sudo tcpdump tmpreaper unzip vim wget zip wireshark 
thunar thunderbird bum gconf-editor geany gqview xclip vlc 
gstreamer0.10-plugins-ugly-multiverse dictionaries-common iamerican 
ispell wamerican lm-sensors mythtv-frontend mythtv-theme-mythcenter 
mythflix mythmusic mythstream mythweather
     # 385M used + 69.2M for Wine + 376M for OpenOffice (+ Java)
x aptitude clean
     # df = 2.7G used
x Test Myth
     = Needed to be added to a group and log out/in
     = Works great, even wireless

Other notes:
Dell "Outlet" store:
2) Outlet Laptops/Notebooks for: Home & Home Office
3) "Check Availability & Prices" left sidebar, "Laptops" pulldown
4) Model = "Mini 9 - 910" , then sort by price

WOW, I just tried that an there are only 5, all with Windows, all listed 
as "Previously ordered new" which seems to me means they are returns. 
So much for all the "Ubuntu is returned more crap... :)  The last few 
times I've checked there were pages of them with Ubuntu, starting as low 
as $189, I got mine for $220.  There is *nothing* with Ubuntu now.  I 
wonder if they took them off?  Or if they are just out.  :-)

* $21 2G RAM  =

* $47 16G SSD
NOTE: Mini-9 has a half height mini-PCI-e slot, some cheaper full-size 
SSD's wont fit.  Watch out!

If anyone actually reads this far, well, that's 10 minutes of your life 
you don't get back...  I hope it was useful...  :-)
JP Vossen, CISSP            |:::======|
My Account, My Opinions     |=========|
"Microsoft Tax" = the additional hardware & yearly fees for the add-on
software required to protect Windows from its own poorly designed and
implemented self, while the overhead incidentally flattens Moore's Law.
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --