JP Vossen on 6 Dec 2009 13:04:54 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Virtual Setup Suggestions Wanted

I recently tried using ESXi v4.0 for a test/dev setup at work.  It 
failed utterly, even with lots of help from Lee (not his fault, obviously).

First, as noted v3.x (3.5 IIRC) and v4.0 are both *very* picky about 
hardware, and v4.0 is 64-bit only.  I got ESXi 3.x installed at one 
point, but didn't really try to do much with it.  I *did* try to do 
things with v4.0 and it was worthless for my needs.

Second, there are philosophical and budget issues.  From the OP, I 
suspect Casey's budget for this is squat and that was my budget as well 
(it was kinda of a "shadow IT" project).  While "ESXi" itself is 
technically "free of cost", for even  partial functionality, including 
the ability to create & use "template" VMs, which was important for me, 
ESXi requires a *Windows-based* "Virtual Center Server" and a license 
for around $1,000.  For full functionality, which was vast overkill, 
lots more hardware and licensing would be required.

Maybe, for Casey, creating 3-5 VMs from scratch, and backing them up 
from inside themselves (since ESXi is on bare metal w/o backup 
facilities) is OK.  For my purpose at work, that was not usable.  I fell 
back to VMware Server 1.x on CentOS-5.3 which has been working great. 
(Yes, I know VMware Server 2.x is current, but I loath the browser-based 
interface and have never gotten it to work right anyway.  And yes, 
tweaking it for every kernel update is annoying.)

I've tried VirtualBox on Hardy but had some issues with keyboard capture 
and such.  It's probably time to try it again, but I doubt I'll get to 
it.  Maybe under the next Ubuntu LTS.

So, VMware for no budget and maximum usability is only, IMO, VMware 
Server 1.x on top of Ubuntu or CentOS [1].


[1] VMware Server 1.0.9 on top of CentOS-5.3:

1) 9.0.10 is out, but wasn't at the time I did this.  Update the URL as 
2) My server had more than 8G RAM, but a 32-bit OS, so it needed the PAE 
kludge.  If you have less than whatever the cutoff is (4G, 8?  I 
forget), you will need to edit the PAE stuff below.
3) For a Debian or Ubuntu server, you need to get the tarball installer 
and use that, since they don't have .debs.  I use a lot of 
FC/CentOS/RHEL at work, so I needed to use that.
4) My server was a *really* minimal install (had < 100 packages on base 
installed), so I ran into errors a more crufty "stock" install might not 
5) My server install does NOT have a GUI, or any more X than required by 
VMware.  All access is via the fat client console, or SSH into the VMs.

* /root/Unpackaged: wget

* Install VMware Server: [root@testbed Unpackaged]# rpm -i 

* Fix error about "ldd /usr/bin/vmware missing libs":
### I did a lot of goofing around, so I'm only about 90% sure this list 
is correct! And this is stuff that VMware Server 1.x *required*
# yum install perl glibc kernel-PAE-devel make xinetd libICE libSM 
libX11 libXau libXdmcp libXrender libXt libXtst zlib

	- kernel headers were in /usr/src/kernels/2.6.18-164.el5-PAE-i686/include
JP Vossen, CISSP            |:::======|
My Account, My Opinions     |=========|
"Microsoft Tax" = the additional hardware & yearly fees for the add-on
software required to protect Windows from its own poorly designed and
implemented self, while the overhead incidentally flattens Moore's Law.
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --