Lee Marzke on 13 Jul 2010 12:38:44 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] really dumb ubuntu question

On 07/12/2010 07:12 PM, Chris Nehren wrote:
On Jul 12, 2010, at 6:56 PM, Conor Schaefer wrote:

Ubuntu is pretty user-friendly, yes, but if you broke wireless in a terminal, you'll probably have to fix it in a terminal.

Have you tried a simple "ls -l /usr/lib"? Tell her to look through that output for signs of a broken symlink, which should stand out in red. You could also use find with a pipe to grep to return only symlinks.
Er. If whoever's operating the machine is smart enough to look through /usr/lib for broken links (and then fix them), surely they're smart enough to have fixed it and circumvented the parental policy in the first place?

I wholeheartedly echo the "don't mess with the filesystem" advice. There's a dozen different, better, less brittle ways of doing what you want, even PolicyKit (/me shudders).

Even better, put a rules on the house firewall about what PC's are allowed Internet access ( and what hours ), usually implemented by MAC address, then this problem wouldn't
have occurred.

Endian UTM, which I'm talking about tonight at PLUG North has this feature.


In the future, try editing the /etc/group file to remove her account from editing network connections.

On Jul 12, 2010 6:49 PM, "Stephanie Alarcon"<steph.alarcon@gmail.com>  wrote:

Well fancy that, 2 messages my first day on the list. Timing couldn't
be better. Sorry for the intrusion, hope this is a simple one...

A while ago I put Ubuntu on a an old Dell for my niece. Her parents
have a no-internet-in-your-room rule, so they asked me to disable
wireless. Well, she's at a writing camp outside of DC and needs the
wireless back. I think all I did was break a symlink between two .so's
in /usr/lib, but without the machine in front of me, I can't remember
exactly what to tell her to do, or what hardware she has.

But this is Ubuntu, so there's got to be an easy way to fix it in the
gui, right? Can she somehow delete the device, re-add it, and do a
system update to get back to a healthy state?
This isn't Windows. Unless the .so you broke was for a device driver (dynamic libs in userspace for a device driver? I don't think so), "reinstalling" the device won't fix the problem. Assuming that you did, indeed, break a .so link, you've got to fix the link or, failing that, find which package it was in and reinstall the package (hoping it doesn't blow up because you've changed the state of reality out from under it).

"Between subtle shading and the absence of light lies the nuance of iqlusion..."  - Kryptos

Lee Marzke,  lee@marzke.net   http://marzke.net/lee/
IT Consultant, VMware, VCenter, SAN storage, infrastructure, SW CM
+1 484-961-0369  voice         +1 484-348-2230 fax

fn:Lee Marzke
tel;work:800 393 5217
tel;fax:484 348-2230
tel;cell:484 961-0369

Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug