Amul Shah on 21 Mar 2012 19:23:42 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] PLUG W follow-up

On Tue, Mar 20, 2012, at 04:14 AM, JP Vossen wrote:

> After the preso Amul & I were talking about enabling VNC on Ubuntu 
> 10.10.  Using the GUI this would be System > Preferences > Remote 
> Desktop, but he doesn't have the GUI, that's the point behind needing 
> VNC in the first place.
> So from the command line via SSH:
> # As the user who owns the GUI desktop
> # This will show you the current settings
> $ gconftool-2 -a /desktop/gnome/remote_access
> # This will show only the ones we care about:
> $ gconftool-2 --get /desktop/gnome/remote_access/enabled
> $ gconftool-2 --get /desktop/gnome/remote_access/view_only
> $ gconftool-2 --get /desktop/gnome/remote_access/prompt_enabled
> # This will set them so that:
> # [x] Allow other users to view your desktop
> # [x] Allow other users to control your desktop
> # [ ] You must confirm each access to this machine
> $ gconftool-2 --set --type=bool /desktop/gnome/remote_access/enabled true
> $ gconftool-2 --set --type=bool /desktop/gnome/remote_access/view_only false
> $ gconftool-2 --set --type=bool 
> /desktop/gnome/remote_access/prompt_enabled false

JP, I giggled up the same incantations, but they didn't work. For some reason
when I tried to start "DISPLAY=:0.0 /usr/lib/vino/vino-server" over the SSH
connection, it wouldn't work. Once I did "xhost +" from a root shell to worked.

When connecting from Mac OS X using the built-in VNC, you want to enable
the password [1] and set the password [2]

[1] gconftool-2 --set --type=bool /desktop/gnome/remote_access/prompt_enabled false
[1] gconftool-2 --type string --set /desktop/gnome/remote_access/authentication_methods vnc

[2] gconftool-2 --type string --set /desktop/gnome/remote_access/vnc_password $(echo -n 'password'| base64)

Even with VNC access, the bluetooth keyboard setup still isn't working. :(

> HOWEVER...  I just tried the stuff above and it didn't seem to work. 
> I'd get a useless "Connection Closed" message immediately on trying to 
> connect.  So I went upstairs to check the machine and it seemed correct. 
>   A 'netstat -lnp' only showed this, which looked odd since it seems 
> IPv6 only while I'm using IPv4:
> 	tcp6  0  0 :::5900    :::*  LISTEN      30673/vino-server
> I didn't change anything, but when I went back to my office and tried 
> again it sort-of worked, in that I could connect, but once it painted 
> once the screen wouldn't refresh.  Then I remembered that VNC and Compiz 
> don't play nice, at least in the Ubuntu 10.04 LTS that I'm using. 
> System > Preferences > Appearance > Visual Effects = None "fixes" that. 
>   (Remote desktop using Ubuntu 10.04+ with Compiz & Unity ought to 
> be...interesting...)
> So maybe:
> $ gconftool-2 -s --type bool /apps/metacity/general/compositing_manager 
> false
> # Or probably better:
> $ gconftool-2 --set /desktop/gnome/remote_access/disable_xdamage --type 
> bool true
> See
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --