Casey Bralla on 14 Apr 2012 14:52:52 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Rsync failing in cron due to ssh permissions

Same problem here... but I never found a good solution.


My work around has been to do stupid security things to open up the file permissions. Luckily for me, I'm in a very closed network, but if anybody here found out the details of what I did, I'd be flamed for sure! <grin>




On Saturday, April 14, 2012 05:42:16 PM Bill East wrote:

I've got a simple task, rsyncing a couple of directories. So I first tested in command line, then in a shell script, then in cron. The first two... worked. The last... didn't. Cron reported "failed to exec ssh - Permission denied (13)" So after some fruitless fiddling around I thought to try ssh on its own. A shell script that just did 'ssh -vv -l user -i /path/to/key destination.domain touch fred.txt'

Again, worked from the command line and the script, failed from cron. I got the incredibly helpful cron error:
/usr/bin/ssh: Permission denied.

So... /usr/bin/ssh is set to 755. I don't see anything in /etc/ssh/ssh_config that would prohibit cron from running it. The cron daemon itself is running as root - it's Dillon's crond if that's important.

Thoughts? Is this so painfully obvious I just can't see it?




Casey Bralla

Chief Nerd in Residence

The NerdWorld Organisation

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --