K.S. Bhaskar on 10 May 2012 13:56:16 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Bizarre proxy behavior after upgrading a partition from 11.10 to 12.04 LTS

I experienced such bizarre behavior with Ubuntu 12.04 LTS on my laptop that I am at a bit of a loss as to where to start troubleshooting.

First, a description of my laptop configuration. ÂI have two root partitions, each mounting the other as /spare. ÂBefore a version upgrade, I clone the current root to /spare (requiring me to only edit /etc/fstab and /boot/grub/grub.cfg after cloning to make a viable partition). ÂI boot into the cloned partition as / and upgrade it, leaving the original partition untouched. ÂPossibly not germane to the problem, but worth mentioning is that I use an encrypted /home partition. ÂAfter booting, I login as root from a text console to mount the encrypted /home before logging in as a normal user to kdm to run KDE.

Definitely relevant to the problem is that I take my laptop home every day. ÂAt work, I must go through a proxy server that requires authentication; at home I do not unless I am connected to my employer's network via VPN. ÂI use the KDE System Settings network proxy dialog to toggle between a manually set proxy at work and no proxy at home. ÂI use chromium as my browser. ÂI have the "use same proxy for all protocols" box checked.

On Tuesday, I booted into the cloned partition and ran the upgrade as I worked. ÂIt went smoothly and when I booted into 12.04 at lunch, everything worked correctly. ÂWhen I took it home, and used it without a proxy, it ran correctly. ÂBut the next morning, at work, after I set the proxy, chromium would not connect, saying it was configured for a proxy server it could not find. ÂKDE's own rekonq browser, could use the proxy and connect via http but would not connect via https. ÂAfter some flailing, I rebooted into the old 11.10, found that things worked, then booted into 12.04 and found it working. ÂSo, putting it down to operator error, or cosmic rays, or whatever, I continued with 12.04 the rest of yesterday. ÂLast night, it again worked correctly at home. ÂBut this morning, at work, again, chromium refused to connect and rekonq would only connect via http. Â[I suspect that the reason chromium refuses to work at all is that it tries to use https everywhere, whereas rekonq will use http.]

I booted into Gnome, and Chromium worked with the proxy set via the Gnome control center.

Checking to see if there was a patch of some kind, I tried sudo aptitude update, which uses a different userid for the proxy, a service account defined in /etc/apt/apt.conf. ÂBut from shell sessions in KDE, Gnome, and a text console, aptitude complained that it could not connect.

So, I booted into my 11.10 partition and am running it. ÂBut the behavior is so bizarre that I don't even know where to start troubleshooting. ÂAny suggestions welcome. ÂThanks in advance.

-- Bhaskar

Windows does to computers what smoking does to humans
Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug