Casey Bralla on 15 Jun 2013 05:07:26 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Strange Wireless Problem

A neighbor gifted me with an old, but rather nice P3 portable.  Naturally, 
I've wiped W98 from this puppy and have loaded LXDE on top of Debian Sid.  The 
weird thing is the wireless.

I bought a cheap ($8 with shipping) USB wireless dongle that is recognized by 
the kernel (although it needs "non-free" firmware from the Debian 
repositories).  It has the Realtek 8188CUS chip, which has been in the 
mainline kernel for some time.

Even though the adapter clearly shows up as wlan0, and can even search and 
identify several ESSID's from my various WAPs, it cannot connect and get a 
DHCP address.  If I try to connect to an encrypted WPA, it fails with a "bad 
password" error (even though I am 100% certain the password was entered 
properly).   Even if I try to connect to a unencrypted site, it still will not 

Since I have lots of old junk lying around, I tried using another dongle 
(which worked) and several wireless PCMCIA cards (some of which would not 
create the wlan0 interface, and some of which had the exact same error).  
Oddly, one old PCMCIA card worked great.

I also tried loading Knoppix live, which had the exact same problem.

I tried the dongle on a WinXP machine, and it worked fine.  I tried it on 
several other Linux boxes, with no connection.

I could use the one working PCMCIA card on my new portable, but I would much 
rather use the $8 small form factor USB dongle. 

So how the heck do I go about trouble-shooting the root cause of this odd 
state of affairs?

To summarize:

wlan0 is created and looks fine, but won't connect.  The device works fine under 

How the heck do I diagnose the problem?

Casey Bralla

Chief Nerd in Residence
The NerdWorld Organisation
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --