Eric H. Johnson on 25 Feb 2014 13:05:47 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Porting Wordpress

Doug, et al,

Thanks for all of the quick replies. I am going to start with this one. How
do I make .htaccess writable? I did a chown to root:www-data to match the
other configuration file, and chmod to rw-rw-rw. After saving permalinks I
got a message that htaccess was successfully written.  Ialso  did a restart
of Apache. I am not using nginx. Unfortunately It did not appear to affect
the problem.


Make sure .htaccess is writeable by the Apache user, as that's where the
permalinks get handled. (If you're using Nginx, you have to make changes in
the .conf files.)

On Tue, Feb 25, 2014 at 3:38 PM, Doug Stewart <> wrote:
WP Admin->Settings->Permalinks. Make sure you click "Save Changes".

On Tue, Feb 25, 2014 at 3:36 PM, Eric H. Johnson <>
Hi all,
Any Wordpress gurus out there? I am trying to help port a Wordpress site,
but have never used Wordpress before. I have setup an Ubuntu 12.04 server
with a LAMP stack and had no trouble installing Wordpress from the
repository, including pointing apache at the appropriate folder. I then blew
away and imported the  database for the site and copied the wp-content
folder to /usr/share/wordpress. Wordpress admin comes up fine and I patched
the wordpress address and site address.
The content seems to be there as I can access and edit pagest from Wordpress
admin, and the home page comes up fine. The problem is that none of the
links resolve,  I just get 404 errors. These links of course resolved on the
original site. The Apache log simply states ?File does not exist?. The paths
look correct as for example I have also tried
using the page id such as which generates
the same error.
I saw something about doing a search and replace with a serialize aware
tool, but the only place I see URLs that could be replaced are in the guid
field of the wp_posts table, where I also saw that those should not be
touched. I am not seeing links of the form appearing in that column anyway,
so don?t think that is the problem.
I think I patched the configuration files correctly because the home page
comes up properly, can access the appropriare database, etc.
Any ideas what I should be looking for?

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --



Philadelphia Linux Users Group         --
Announcements -
General Discussion  --