Tom Haines on 3 Nov 2015 18:57:20 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Sound and MKV files

I recommend the open source mediainfo command line tool to get a good handle on exactly what kind of audio is actually in the file. I'm not sure what the Panasonic TV's actually support, but I have hard drive full of MKV files with h.264 video and DTS audio and they all play fine on my Panasonic TV (admittedly I haven't tried with a Chromecast).

If you want to play around with different audio formats quickly you can use FFMPEG to just copy the video essence and re-encode the audio with:

ffmpeg -i infile.mkv -c:v copy -c:a dts outfile.mkv

This will prevent the video from being re-encoded which can be a long process. I've found Handbrake always wants to re-encode the video which makes experimenting with codecs a painful process.

On Tue, Nov 3, 2015 at 9:47 PM, Eric H. Johnson <> wrote:

Hi all,


Not strictly a Linux question, but same symptoms on any platform I tried. I have two TVs with Chromecasts, one is a Sony, the other a Panasonic.  If I chromecast an mkv to the Sony TV, no problem. If I do the same to the Panasonic, I get no sound. I swapped chromecasts, so it isn’t something with the chromecast. Also, if I have a file format other than mkv, mp4 specifically, then I do get sound to either TV.


The first computer I was using is running Ubuntu Linux 15.04. I then tried with a Windows 7 machine, same thing. Sound to the Sony, no sound to the Panasonic. I then copied the file to an Android tablet with an HDMI port.  Again no sound to the Panasonic, although I did not try the Sony. One of my Linux laptops has an HDMI port, so I tried with it, again no sound to the Panasonic.


I read online that there are a couple types of sound encoding that chromecast does not support, including AC3, however the sound encoding appears to be AAC. Finally I transcribed the file from MKV to mp4 with handbrake, but the resulting file has no sound regardless of where it is played, including locally.


What the heck am I missing?





Philadelphia Linux Users Group         --
Announcements -
General Discussion  --

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --