Bill Patterson on 29 Jan 2016 08:59:48 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Apache2 weird problem

Thanks, but I did try reinstalling apache2-bin although I hadn't said that in my original post. 

I also rebooted the machine several times.  I went through two cycles of remove purge and install.  It is frustrating as I also have been using browser to hunt all over the Internet for anyone having this problem and no one seems to have this exactly as it has happened to me so far in my search.


On 01/29/2016 12:04 AM, Josh Zenker wrote:
On my Ubuntu 14.04.3 system, it looks like the apache2 binary is actually installed by the apache2-bin package.

$ dpkg -L apache2-bin | grep '/usr/sbin'

Have you tried reinstalling apache2-bin? I believe it is a dependency for apache2 and may not have been reinstalled in your previous steps.

On Thu, Jan 28, 2016 at 11:34 PM, Bill Patterson <> wrote:
Dear Colleagues -

I don't know how it happened.  I was debugging PHP with NetBeans, and after a distraction I went back to it and found that the server wasn't running.  I tried to restart Apache.  I completely removed and purged it and reinstalled it.  It now says it is installed but if I type "apache2 -v" it says the program isn't installed:

me@mymachine:~$ sudo apt-get install apache2
[sudo] password for me:
Reading package lists... Done
Building dependency tree
Reading state information... Done
apache2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 69 not upgraded.
me@mymachine:~$ apache2 -v
The program 'apache2' is currently not installed. You can install it by typing:
sudo apt-get install apache2-bin

any ideas?

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --