Josh Zenker on 24 Feb 2016 18:21:21 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Public Wifi

I think the DNS change is probably your answer. Network admins often implement captive portals like the one you're describing by poisoning DNS to return the captive portal IP for all forward lookups. If you were previously accepting whatever DNS servers were offered by the DHCP server, this explanation fits.

I'm unsure why restoring your backup of the config didn't help though. If you're using something like NetworkManager to manage your connections, you might be able to force it to generate a fresh config.

On Wednesday, February 24, 2016, Ken Smith <> wrote:
Hey I was wondering if anybody ever had any problems with a login page for public wifi not loading on linux?
I am having this issue at school and at the library. 
Each of the wifi's redirect you to a login page when connecting. The first time I connected to these wifi's
I was redirected and the connection worked fine, but ever since then I wont be redirected to the login page.
The only thing that I changed recently was my resolv.conf file to change DNS servers to google from comcast.
I tried changing back to the backup of the original resolv.conf but same issue. Tried some googling but havent
found anything yet. My android is not having any issue with the connection or the redirect. Any ideas?
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --