Rich Mingin (PLUG) on 20 May 2016 07:30:22 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Trapped in hibernate

Sounds like your partition is busted (technical term) and the disk should be wiped or at least the partition needs to be reformatted. Windows reinstall is trying to reuse the existing file system, but it's unclean and sounds damaged. I wouldn't ever reinstall Windows to a partition that already had a Windows install, the new graft rarely lives long.

For recovery of this type of scenario in the future, I usually either attach the physical disk to an existing Windows VM of the same version, or spin up a new one and do the same. This lets you check and repair the filesystem from a known-good install. Your understanding of the RO mount and failed install is good, but the method you used to repair it isn't cutting it.

On Fri, May 20, 2016 at 10:24 AM, Eric H. Johnson <> wrote:
Hi all,

This is more a Windows problem than Linux, but maybe someone has encountered it.

I have a Dell laptop running Windows 7 pro that crashed coming out of hibernate. It first said a file was corrupt, unfortunately I did not write it down. Startup repair was able to repair that file however.

Now it just runs startup repair and after several times trying, says startup repair cannot repair this computer automatically. Looking at repair details, it says number of root causes is 1, but all checks seem to have passed.

While I can get to a command prompt, I was not able to directly access the file system or copy off the existing files. I booted to a Linux live CD and was able to back up all files. The odd thing was that I could not directly mount the drive because it was still tagged as in hibernate mode, or some such thing.

I was able to mount the drive read only and backed up all of the files that way.

I then tried to reinstall Windows. Other than startup repair, it does not give an option to repair the existing install, so I tried to install another instance along side. It got to step 2, expanding files and just sat on 0% for several minutes before saying it could not install, but gave no other error message.

A couple other notes, Dell does not ship recovery media and the HD in the computer was previously replaced and has no recovery partition. I don't know the windows product id, but expected a reinstall would find the existing one. Downloading the install image from MS requires the product id, so I just used a generic windows 7 64 bit iso for the install media.

At any rate, could the reason I cannot install be that the hibernate flag is still set, and is there any way to reset it? Any other ideas?


Sent from my Android device with K-9 Mail. Please excuse my brevity.

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --