JP Vossen on 21 May 2016 15:14:51 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Ansible on Debian 8

This command previously Just Worked for Ansible to and all previous Ansible upgrades:
	$ sudo pip install --upgrade ansible

But today it suddenly failed all over the place for Ansible on Debian 8.

Long story short:
	$ sudo apt-get install python-dev libffi-dev libssl-dev
	$ pip install --ignore-installed ansible

I might have been able to just do another `sudo pip install --upgrade ansible` for that last command, but by then I'd done a whole lot of other things thrashing around trying to figure it out, so...

Errors at various times in the process included:
* build/temp.linux-x86_64-2.7/check_libyaml.c:2:18: fatal error: yaml.h: No such file or directory
* src/MD2.c:31:20: fatal error: Python.h: No such file or directory
* c/_cffi_backend.c:15:17: fatal error: ffi.h: No such file or directory
* build/temp.linux-x86_64-2.7/_openssl.c:423:30: fatal error: openssl/opensslv.h: No such file or directory

It seems to be something about Paramiko changing dependencies, but I never found anything that fully answered my problem. I pieced the above together from: * * *!msg/ansible-project/dFRlLiUI4PA/qsO3y4czDAAJ

Note I was upgrading because I usually hit on at least 1 machine per weekend update of only 16 hosts, not a great stat. A re-run for that host works, but I shouldn't have to do that... I guess I'll see if that worked next weekend.

--  -------------------------------------------------------------------
JP Vossen, CISSP | |
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --