Keith C. Perry via plug on 2 Nov 2019 15:11:58 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] USB audio recognized but not working

Dumb questions...

1) have you tried inserting the USB device in after the system is completely up?
2) Does the USB device so up in output device in pavucontrol?

I'm haven't upgraded yet to 18.04LTS but my Roland M-1000 digital mixer runs 100% (I almost always push audio to my studio speakers) as does my midi-transport (though I haven't used it in awhile).  Between that and my DECT headset and HDMI monitor speakers I've actually come to appreciate using pavucontrol for audio routing.  Only thing that tends to happen is that I have to manually restart pulseaudio when I turn a device on or off (if I want the view to be accurate).  Have you tried restarting pulse once the system is completely up and the USB device is on?

~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~
Keith C. Perry, MS E.E.
Managing Member, DAO Technologies LLC
(O) +1.215.525.4165 x2033
(M) +1.215.432.5167

From: "Eric Lucas via plug" <>
To: "Philadelphia Linux User's Group Discussion List" <>
Sent: Saturday, November 2, 2019 10:16:20 AM
Subject: [PLUG] USB audio recognized but not working

I'm installing kubuntu 18.04 on my laptop. 
I have a USB audio device, a Behringer UCA202 connected to my external speakers. 
In the previous (Fedora 26) incarnation it just worked. 
Now it fails. 

The device appears to be recognized: (from dmesg...)
[ 9703.823862] usb 1-3: new full-speed USB device number 10 using xhci_hcd 
[ 9703.975428] usb 1-3: New USB device found, idVendor=08bb, idProduct=2902, bcdDevice= 1.00
[ 9703.975435] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 9703.975439] usb 1-3: Product: USB Audio CODEC  
[ 9703.975442] usb 1-3: Manufacturer: Burr-Brown from TI               
[ 9703.998851] input: Burr-Brown from TI               USB Audio CODEC  as /devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.3/0003:08BB:2902.0011/input/input36
[ 9704.057079] hid-generic 0003:08BB:2902.0011: input,hidraw3: USB HID v1.00 Device [Burr-Brown from TI   USB Audio CODEC ] on usb-0000:00:14.0-3/input3

...however all audio comes from the laptop speakers instead of through the USB audio (preferred!)
I notice it says "input" but there is no "output". 

What am I missing here?


Philadelphia Linux Users Group         --
Announcements -
General Discussion  --
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --