JP Vossen via plug on 3 Jan 2022 17:47:31 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Very weird error with make (constant segfaulting)

On 1/3/22 9:11 AM, Lynn Bradshaw via plug wrote:
So I was about to start compiling some software project and make
segfaulted. I thought it might have been a fluke, so I tried again,
same thing, repeatedly. Tried backing out of the shell or tmux
altogether, restarting the terminal emulator, using bash (normal
choice is zsh on this one) and ultimately only restarting the entire
machine fixed it.

I don't think it's dodgy hardware because a) only make has ever done
this (I think it's the second or third time now) and b) the hardware
in question is reasonably new and also c) the uptime that of course
got wiped out was nearly three weeks. The one hardware possibility
that comes to mind is that it's a Raspberry Pi (four cores, ARMv7
Processor rev 3 (v7l)) and something just slipped under the radar that
maybe wouldn't have if it had been an Intel or Intel-like processor.

I had a very similar problem on an rPi1 when I was first turning it into an NTPSec server.  One odd aspect to my issue what having to go delete *.pyc files after every attempt.  I think a reboot helped, once each, in that case too.

The *real* problem was the SD Card!  Once I replaced that everything Just Worked.  I can't explain it, and it was a few years ago so the details are hazy, but a new and better SD card fixed it.

--  -------------------------------------------------------------------
JP Vossen, CISSP | |
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --