Joel L. Breazeale on Mon, 26 May 2003 12:07:07 -0400

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [tcptra-dev] tcptraceroute-1.5beta1


I just received your message and have not tried v1.5 beta2.  I will do so shortly.

I thought it would be prudent to forward a few comments from Jerry Talkington.
He has tcptraceroute v1.4 working on MacOS X.  He used the -DHASSALEN as a
compilation option.  If you would like me to try anything related to this then
just let me know.


--- forwarded message ---
From: Jerry Talkington <>
To: "Joel L. Breazeale" <>
Subject: Re: [tcptra-dev] tcptraceroute-1.5beta1

I haven't tried that version yet, but I just got the 1.4 version working
by specifying -DHASSALEN on the command line.  I'm having the same
problem, though, even when I try to access machines inside my

You may want to try asking the tcptraceroute development mailing list.

--- end forwarded message ---

> > I used --no-select and found better results for and
> > Side-by-side results follow:
> [..]
> >     $ sudo ./tcptraceroute --no-select
> >     Selected device lo0, address, port 49518 for outgoing packets
> >     Tracing the path to on TCP port 80 (http), 30 hops max
> >      1  localhost ( [open]  0.333 ms  0.244 ms  0.186 ms
> Okay, so it looks like --no-select should be the default on MacOS X.
> Based on the output of "gcc -E -dM - </dev/null" on your machine, it
> would seem that we can detect MacOS X systems by checking for the
> presence of __APPLE__ and __MACH__.  I just patched the
> file so that autoconf should now do just that, and make --no-select the
> compile-time default for MacOS X.  Can you please confirm that it's no
> longer necessary to specify the --no-select command line argument by
> hand with tcptraceroute-1.5beta2?
>   <>
> > Here's the non-local case too w/ and w/o --no-select:
> [..]
> >     $ sudo ./tcptraceroute --no-select
> >     Selected device en0, address, port 49529 for outgoing packets
> >     Tracing the path to on TCP port 80 (http), 30 hops max
> >      1  * * *
> >     ^C
> Hmm.  Earlier you included a traceroute to, which was one
> hop away.  Is that the address of your local machine, or the address of
> a NAT device external to your MacOS X system?  If it's an external NAT
> device, I wonder if it could be interfering with tcptraceroute.  Can you
> please try executing the following commands, and sending back the output
> from each?
> 	tcptraceroute -q1 -d
> 	tcptraceroute -q1 -d
> 	tcptraceroute -q3 -f30 -d
> 	traceroute
> 	telnet 4242
> Thanks,
> -mct
> _______________________________________________
> tcptraceroute-dev mailing list

tcptraceroute-dev mailing list