Jason Staloff on Fri, 9 Apr 1999 00:21:31 -0400 (EDT)

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

setting TERM from a script

When I log in to my ISP shell account from Linux, neither vi nor pine will
work because TERM=linux. This being unacceptable, I set TERM=vt100; export
TERM (my shell is bash), and it's fine for that session. So I'm thinking,
what a great job for a little shell script...

#!/bin/sh (yes that's where it is, I checked)
export TERM

When I run it, there's no error but TERM is still linux. What's up?? I
tried with #!/bin/bash, too, no dice.

I also get the error from work logging in from Wind95's telnet client,
which sets TERM=ansi. If I could get my sophisticated two-liner to work,
I'd put it in .bash_profile and go on to live a happy life.


Bonus Question: while I was writing this, my telnet session on the PC timed
out, and I couldn't get back to my local shell. ^z and ^d didn't help. I
had to ctr-alt-del! The system shut down and came back up in an orderly
fashion but it's really disturbing that such a thing was necessary. What
could I have done to avoid rebooting? (This session was at the shell
prompt, X wasn't running, so I couldn't use kill.)

To unsubscribe, send a message with the word 'unsubscribe' in the subject
or body of your message to plug-request@lists.nothinbut.net