Steve Gran on Tue, 24 Apr 2001 10:54:39 -0400

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Printer failure

I'm fairly new to Linux - I've had a Debian box for about four months.  I'm running Debian's Woody distro on an AMD K6-2 cpu, with kernel v. 2.4.2.  The problem I'm having is a total printer failure.  I upgraded the kernel from v. 2.2.18 at about the saame time that I ran apt-get dist upgrade, and now the printer is an attractive block of plastic.
The steps I've tried so far:
dmesg reports that my box can find the printer on boot (it reports an HP 710, and I'm actually using an HP712c, but they're the same family, so I assume tthis is no big deal).
lpr foo.txt seems like it works - a large enough file will pause for a moment before returning to the prompt, and an immediatew lpq will show foo.txt in the printer qeue.  It will then disappear and nothing comes out of the printer.
cdat foo.txt > /dev/lp0 does essentially the same thing - it will pause as though it's sending the file, then return to the prompt with out anything coming from the printer.  Same for cat foo.txt > /dev/par0.
lsmod shows that lp.o, parport.o, parport_pc.0 are loaded.
/etc/init.d/lpd restart returns normal values - stopping printer spooler:lpd, starting printer spooler:lpd.
tunelp /dev/lp0 -s reports: /dev/lp0 status is 216, on-line.
tunelp /dev/lp0 -r reports: /dev/lp0 usinf IRQ -1.  This seems to be troubling, as dmesg reports the parport is using IRQ 7 - I tried to make tunelp force /dev/lp0 to use IRQ 7, without success.
I tried regenerating my magicfilterconfig file - no changes, although I believe that the cat command should have bypassed the filter, so I don't think that's the problem.
I can't think of what else to do.  If anyone can help, I would really appreciate.

Philadelphia Linux Users Group       -
General Discussion  -