Cosmin Nicolaescu on 5 Aug 2005 14:43:31 -0000

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Fedora 3 problem with modules

Hash: SHA1

On Fri, August 5, 2005 10:32 am, George Gallen wrote:
> I have a system I havn't used in a few months
> that I'm now trying to use. The problem is the
> ethernet port. It is not recognized.
> The hardware browser finds it, but it doesn't
> get added into the system.
> I booted Knoppix, and it worked just fine.
> after much fooling around, I found that when
> the modprobe is done, the module can't be found
> (8139too). However, the 8139too.ko file is in
> the modules directory.
> Any Ideas why it can't be found? It is not in
> the /proc/modules list and insmod gives me a -1
> status and doesn't add in the module.
> I tried a few other modules that are there, but
> they all come up as module not found.
> I tried re-installing the system (FC3) but that
> didn't fix it. I'd rather not do a fresh install
> if possible.
> Tonight, I'm burning the FC4 Cd's, and can try upgrading
> to the FC4 level, but I get the feeling this may not
> fix it either.
> a few months ago, I tried to get the USB wireless LAN to
> function, and I'm wondering if I clobbered something in
> the process??
> I've tried deleteing all the networks and all the hardware
> and adding in a new eth0 with the appropriate hardware, but
> when I activate it, I get the module not found error.
> How do I convince the system I really DO have the modules?
> or are the .ko files not the actual module?
> George
> ___________________________________________________________________________
> Philadelphia Linux Users Group         --
> Announcements -
> General Discussion  --

No, the .ko files are in fact modules.

Try this, maybe it will work:

ls -l /lib/modules/`uname -r`/kernel/drivers/net/8139too.ko.

If the file is there, and everything seems ok (not 0 size, not symlink
etc), then the module is there and the kernel should find it. Try running
'depmod -a',  and then try modprobing 8139too again.

If it doesn't work, maybe we can fingure out something else.

Also what you might want to check (although I doubt it) is the permissions.
After getting the output of ls -l above, and the persmission on the file
are 644, try:

cd /lib/modules/`uname -r`/kernel/drivers/net/
ls -ld .
cd ../
ls -ld .
cd ../

Until you reach the top level. But since all those directories are created
by the kernel install (or RH), that shouldn't be a problem.

- -Cos

- --
GPG key fingerprint = DE9F 4664 E666 2BD1 903E  4F4D EA31 5FB1 C7F9 08C1

Version: GnuPG v1.4.1 (GNU/Linux)


Philadelphia Linux Users Group         --
Announcements -
General Discussion  --